Question: Internal server error?
0
gravatar for adeglincer
3.8 years ago by
adeglincer0
United States
adeglincer0 wrote:

Hello, 

My instance of Galaxy seems to have run into an Internal Server Error -- Galaxy seems to be stuck and I have received an error notification a few times now. 

 

Thanks

error • 1.7k views
ADD COMMENTlink written 3.8 years ago by adeglincer0

Hi  adeglincer How did this go? Were you able to figure out the problem? You might know this, but a restart after configuration changes are always a good idea. Hope all is well, but let us know how we can help. As Martin mentioned, the paster log is where the details will be, we can help decode it. -Jen

ADD REPLYlink modified 3.8 years ago • written 3.8 years ago by Jennifer Hillman Jackson24k
0
gravatar for Martin Čech
3.8 years ago by
Martin Čech ♦♦ 4.3k
United States
Martin Čech ♦♦ 4.3k wrote:

You have to provide some details. What version you run, what were you trying to do, what exactly is the error, where do you see it etc.

ADD COMMENTlink written 3.8 years ago by Martin Čech ♦♦ 4.3k

Just trying to run Cufflinks -- ran it yesterday with similar parameters and it was working fine.  Here are the details of the error

 

user

username

adeglincer

quota_percent

68

total_disk_usage

185182188436

nice_total_disk_usage

172.5 GB

email

xxx

is_admin

false

tags_used

 

model_class

User

id

xxx

source

HDACollection(xxx)

xhr

readyState

4

responseText

{"err_msg": "Uncaught exception in exposed API method:", "err_code": 0}

responseJSON

err_msg

Uncaught exception in exposed API method:

err_code

0

status

500

statusText

Internal Server Error

responseHeaders

Date

Thu, 24 Apr 2014 23:59:56 GMT

cache-control

max-age=0,no-cache,no-store

Server

nginx/1.4.7

Connection

keep-alive

Transfer-Encoding

chunked

Content-Type

application/json

options

data

 

parse

true

emulateHTTP

false

emulateJSON

false

ADD REPLYlink modified 3.8 years ago • written 3.8 years ago by adeglincer0

This is not an error detail, this is a response from the API of some Galaxy. Please try to follow the guidelines to receive help. https://biostar.usegalaxy.org/info/about/

ADD REPLYlink written 3.8 years ago by Martin Čech ♦♦ 4.3k

sorry, that's all i got from galaxy and have no idea how i could find out more about the error.  thanks anyway for trying to help!

ADD REPLYlink written 3.8 years ago by adeglincer0

you said you have your own Galaxy, please check the logs of it (file paster.log in the Galaxy folder), there will be more detail about the error

ADD REPLYlink written 3.8 years ago by Martin Čech ♦♦ 4.3k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 92 users visited in the last hour