Question: Workflow renaming problem for tool with multiple outputs (Galaxy version 17.09) - Fix implemented at usegalaxy.org
1
gravatar for valdirbarth
19 days ago by
valdirbarth10
valdirbarth10 wrote:

I have been successfully renaming outputs in my workflow. However I am having trouble renaming the outputs from Trim galore.
I am using the usegalaxy.org server

In the workflow section:

Rename dataset This action will rename the output dataset. Click here for more information. Valid inputs are: singlePaired|input_singles.

I have been using either #{singlePaired}_tg or #{input_singles}_tg and none of them work (no renaming at all). Any ideas why?

workflow galaxy dataset rename • 187 views
ADD COMMENTlink modified 10 days ago by Jennifer Hillman Jackson23k • written 19 days ago by valdirbarth10

I still have not figured this out, anyone?

ADD REPLYlink modified 14 days ago • written 14 days ago by valdirbarth10

An existing ticket for workflow renaming is linked to this prior post: https://biostar.usegalaxy.org/p/14220/ Also, there were some reported renaming issues within workflows for certain input types about a week ago (related to dataset collections) that might be associated. More feedback soon. Thanks!. Jen, Galaxy team

ADD REPLYlink modified 14 days ago • written 14 days ago by Jennifer Hillman Jackson23k
2
gravatar for Jennifer Hillman Jackson
11 days ago by
United States
Jennifer Hillman Jackson23k wrote:

Hello,

A bug fix for workflow renaming was just recently made but it is not included at https://usegalaxy.org yet. It should be soon (at the next server update).

Ticket: https://github.com/galaxyproject/galaxy/pull/5021

I'll mark this post for an update when that is done. However, if you do not hear back in a week or so, please post a comment asking for an update :)

Note: Anyone obtaining a new Galaxy 17.09 local from Github, or updating to the latest patch, will have the bug fix included (https://getgalaxy.org).

Thanks! Jen, Galaxy team

ADD COMMENTlink written 11 days ago by Jennifer Hillman Jackson23k
1

Hi,

Somewhat related to this problem. In my workflow, when I use a tool with multiple outputs, I am not able to set different renaming options to different outputs.

I have found this problem when using bowtie2. The last rename option I introduce will override the other ones and all the seven output renames will be the same once I save my workflow.

ADD REPLYlink written 10 days ago by eggrandio10

Hello - Yes, this was something I noticed yesterday during testing as well and our team discussed it. When the bug fix for the other item comes through all renaming issue will likely be resolved. If not, we'll do another priority fix. Thanks for reporting the issue! Jen

ADD REPLYlink written 10 days ago by Jennifer Hillman Jackson23k

Hi again,

I have fixed my workflow and now everything looks perfect. I can rename different outputs with different tags.

Thank you for such a quick fix !

Best,

ADD REPLYlink written 9 days ago by eggrandio10
0
gravatar for Jennifer Hillman Jackson
10 days ago by
United States
Jennifer Hillman Jackson23k wrote:

Update 12-01-17 2pm EST

Galaxy Main at https://usegalaxy.org has been updated.

Please rerun your jobs and let us know if problems continue. We are also testing today for a few bug fixes and will report back if any issues are still present.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 10 days ago by Jennifer Hillman Jackson23k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 97 users visited in the last hour