Question: Galaxy Cloud EC2 Response Error
0
gravatar for madkisson
3.6 years ago by
madkisson • 30
United States
madkisson • 30 wrote:

Good Afternoon

I'm seeing this cluster error over and over today:

  • 20:23:57 - Adding 1 on-demand instance(s)
  • 20:23:57 - boto server error when starting an instance: EC2ResponseError: 400 Bad Request
  • InvalidParameterValueUser data is limited to 16384 bytes24d3f01c-c4e1-4c1b-8922-27c4829bcfc0

It's repeating over and over in the Cluster Status Log and keeping me from running anything in Galaxy. Is this something I just have to wait out? Thanks

error cluster galaxy cloudman • 830 views
ADD COMMENT • link • modified 3.6 years ago by Dannon Baker ♦ 3.7k • written 3.6 years ago by madkisson • 30
0
gravatar for Dannon Baker
3.6 years ago by
Dannon Baker ♦ 3.7k
United States
Dannon Baker ♦ 3.7k wrote:

(responded offline so we can exchange potentially sensitive information -- will update this post with the results)

Update:

Short answer is that this was a cloudman bug that will only be experienced by repeatedly launching the same cluster (which is expected) many times.  This will be fixed in future releases, but for now the 'fix' for anyone else who hits this bug is:

  1. shut down your cluster the usual way
  2. download persistent_data.yaml from your cluster's bucket
  3. save a backup of this file prior to editing
  4. edit the file with a plain text editor and delete all of the 'tags' that aren't in use anymore
  5. upload this modified persistent_data.yaml, overwriting the old one
  6. start your cluster back up
ADD COMMENT • link modified 3.6 years ago • written 3.6 years ago by Dannon Baker ♦ 3.7k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 171 users visited in the last hour