Question: fastq files are't recognized by tools
5
gravatar for markus.wolfien
3.6 years ago by
Germany
markus.wolfien50 wrote:

Hey,

I'm looking forward to do some NGS analysis and would like to use your provided NGS tools. I uploaded some of my .fastq files (standardized in illumina 1.9) as fastq format. But somehow the tools, e.g. FASTQGroomer, don't recognize the data not as FASTQ. Is this a problem of data preprocessing, uploading or something else? I also tried to upload the files as illuminafastq but the errors are still the same.

Thanks for your efforts and best regards,

mwolfien

rna-seq • 4.0k views
ADD COMMENTlink modified 3.0 years ago by dtabed0 • written 3.6 years ago by markus.wolfien50

Thanks a lot. I changed the datatype and now everything is fine.

ADD REPLYlink written 3.6 years ago by markus.wolfien50

Great!  Since this worked for you, please mark the answer below as accepted.  This allows us to more easily find and help people with questions that remain open.

ADD REPLYlink modified 3.6 years ago • written 3.6 years ago by Dannon Baker3.6k

Hey again,

now it recognizes the data, but during the uplaod (upload as fastqsanger) the fastq file is a kind of malformed. The upload somehow changes the first line of the file and adds the name of the file in front of the first @. Therefore the tools generate an error. May changing the upload procedure will help, because I currently upload the data directly from .tar.gz files and not from a ftp server?

ADD REPLYlink written 3.6 years ago by markus.wolfien50
2

The tar-ing of your file is the problem here. Galaxy doesn't yet support uploading tar.gz (or just .tar) files yet. You can upload a single .gz'd file (no tar), and it will be automatically decompressed on upload.

FWIW, the extra characters at the start of the file (filename, etc) are part of the the tar header.

ADD REPLYlink written 3.6 years ago by Daniel Blankenberg ♦♦ 1.7k
6
gravatar for Dannon Baker
3.6 years ago by
Dannon Baker3.6k
United States
Dannon Baker3.6k wrote:

What datatype are they actually recognized as, if you look at the details in the history panel?  It may be that they actually were uploaded as fastq, but you need to change that to fastqsanger (click the pencil icon on the dataset and then go to the datatype tab) to be able to use particular tools with them.

ADD COMMENTlink written 3.6 years ago by Dannon Baker3.6k
0
gravatar for dtabed
3.0 years ago by
dtabed0
Canada
dtabed0 wrote:

Hi mwolfien,

are you the author of this workflow? if yes i need your help please. sorry for using this thread for other purpose

https://usegalaxy.org/u/mwolfien/w/rnaseq-wolfien-pipeline

Regards,

dtabed

ADD COMMENTlink written 3.0 years ago by dtabed0

Hi dtabed,

Yes, I'm the author of the workflow. If it is possible please add me at sk.y.p.e (markus.w791) and we will find a solution for your problem.

Best regards,

mwolfien

ADD REPLYlink written 3.0 years ago by markus.wolfien50
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 88 users visited in the last hour