Question: 'Internal Server Error Galaxy was unable to successfully complete your request' where is the log?
1
gravatar for Guy Reeves
11 months ago by
Guy Reeves630
Germany
Guy Reeves630 wrote:

Hi

I was trying to update my galaxy instance using 'git pull' which I thought I had done successfully after stopping and restarting. But when I try to access through a web browser I get the following error

'Internal Server Error Galaxy was unable to successfully complete your request An error occurred. This may be an intermittent problem due to load or other unpredictable factors, reloading the page may address the problem. The error has been logged to our team.'

Where is the file that the error is logged? Thanks Guy

updating galaxy error log • 394 views
ADD COMMENTlink modified 4 months ago by anastazie.d20 • written 11 months ago by Guy Reeves630
2
gravatar for Dannon Baker
11 months ago by
Dannon Baker3.6k
United States
Dannon Baker3.6k wrote:

By default it'll be a file called paster.log, but that can be customized. How are you starting and stopping the Galaxy server?

ADD COMMENTlink written 11 months ago by Dannon Baker3.6k
1

to stop: sh run.sh --stop-daemon

to start: sh run.sh --daemon --log-file=/home/galaxy/log/galaxy.log

ADD REPLYlink written 11 months ago by Guy Reeves630
1

Ok, the errors should all be in that file at /home/galaxy/log/galaxy.log

ADD REPLYlink written 11 months ago by Dannon Baker3.6k

HI I do not know if you need the whole log but here is the top few lines thanks Guy

/home/galaxy/galaxy/lib/galaxy/util/pastescript/loadwsgi.py:127: DeprecationWarning: Parameters to load are deprecated. Call .resolve and .require separately. return pkg_resources.EntryPoint.parse("x=" + s).load(False) WARNING:galaxy.config:Sanitize log file %s does not exist, continuing with no tools whitelisted. galaxy.queue_worker INFO 2016-03-03 12:16:42,365 Initalizing main Galaxy Queue Worker on sqlalchemy+postgresql://galaxy:**@localhost/galaxydb tool_shed.tool_shed_registry DEBUG 2016-03-03 12:16:42,709 Loading references to tool sheds from ./config/tool_sheds_conf.xml.sample tool_shed.tool_shed_registry DEBUG 2016-03-03 12:16:42,709 Loaded reference to tool shed: Galaxy Main Tool Shed galaxy.app DEBUG 2016-03-03 12:16:42,753 Using "galaxy.ini" config file: /home/galaxy/galaxy/config/galaxy.ini migrate.versioning.repository DEBUG 2016-03-03 12:16:43,632 Loading repository lib/galaxy/model/migrate... migrate.versioning.script.base DEBUG 2016-03-03 12:16:43,654 Loading script lib/galaxy/model/migrate/versions/0001_initial_tables.py... migrate.versioning.script.base DEBUG 2016-03-03 12:16:43,654 Script lib/galaxy/model/migrate/versions/0001_initial_tables.py loaded successfully migrate.versioning.script.base DEBUG 2016-03-03 12:16:43,655 Loading script lib/galaxy/model/migrate/versions/0002_metadata_file_table.py...

ADD REPLYlink written 11 months ago by Guy Reeves630

What are the very last few?

ADD REPLYlink written 11 months ago by Dannon Baker3.6k

Actually what I sent was at the top of the file and what I am sending now is the bottom.

WSGI Variables

application: <paste.recursive.recursivemiddleware object="" at="" 0x8eb3190=""> is_api_request: False paste.cookies: (<simplecookie: _ga="GA1.2.1672570022.1433345611" galaxysession="c6ca0ddb55be603a727a539f849e064a52b25fd6068b0dbdbb648dfd5ea10c5c4bfdc6e7a143bc6b">, 'galaxysession=c6ca0ddb55be603a727a539f849e064a52b25fd6068b0dbdbb648dfd5ea10c5c4bfdc6e7a143bc6b; _ga=GA1.2.1672570022.1433345611') paste.expected_exceptions: [<class 'paste.httpexceptions.httpexception'="">] paste.httpexceptions: <paste.httpexceptions.httpexceptionhandler object="" at="" 0x7ff260051310=""> paste.httpserver.thread_pool: <paste.httpserver.threadpool object="" at="" 0x9394550=""> paste.recursive.forward: <paste.recursive.forwarder from="" galaxy=""> paste.recursive.include: <paste.recursive.includer from="" galaxy=""> paste.recursive.include_app_iter: <paste.recursive.includerappiter from="" galaxy=""> paste.recursive.script_name: '/galaxy' paste.throw_errors: True request_id: 'c4ac3b48e5d911e5a11600259059f284' webob._parsed_query_vars: (GET([]), '')

wsgi process: 'Multithreaded'

ADD REPLYlink written 11 months ago by Guy Reeves630

Looks to be the context for the error, but not the actual error. Do you want to email me a subset or the whole thing directly? (dannon.baker@gmail.com)

ADD REPLYlink written 11 months ago by Dannon Baker3.6k
2
gravatar for anastazie.d
4 months ago by
anastazie.d20
anastazie.d20 wrote:

Hi, I had the same error. Finally the problem resolved when I typed again new section name, where tool should be installed. Problem was in some weird symbol in section name.

ADD COMMENTlink written 4 months ago by anastazie.d20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 74 users visited in the last hour