Question: Can't install galaxy-ops into toolshed
0
gravatar for njoebott
4 days ago by
njoebott30
njoebott30 wrote:

Greetings Galaxy experts and enthusiasts,

I have a simple single node installation of Galaxy using Ubuntu 16.04.1 and python 2.7.12

I Want to perform a simple join operation (per the 101 tutorial) but cannot fully install the dependencies required: package_galaxy_ops_1_0_0 -> galaxy-ops

This is due to a SSL issue because the external location for this package is behind an https and NOT http:

"Error downloading from URL http://depot.galaxyproject.org/package/source/gops-1.0-st.tgz urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)"

I was able to download the package, gops-1.0-st.tgz with an external browser and tried to install it in the specified directory, to no avail:

./database/dependencies/galaxy-ops/1.0.0/devteam/package_galaxy_ops_1_0_0/eef263ff9b95

So, I am asking the community here how to proceed with:

  1. Installing the package without the SSL issue. Where can I modify the python code to skip the ssl validation? or,
  2. How can I manually install this package and have Galaxy accept it?

Thanks for any guidance here.

galaxy • 18 views
ADD COMMENTlink written 4 days ago by njoebott30
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 74 users visited in the last hour