Question: Local Galaxy problem in adding labels for tools within sections
1
gravatar for qyuan
14 months ago by
qyuan30
qyuan30 wrote:

Hi, I have just installed Galaxy (lib/galaxy/version.py has VERSION_MAJOR = "16.07") locally in a Linux server (Fedora 14) and successfully installed many tools via toolshed. Now I want to add labels to subgroup the tools within sections. I modified the integrated_tool_panel.xml file by re-ordering tools and adding labels ( similar to <label id="bedtools" text="bedtools" version=""/> ). After I restarted the Galaxy, the new orders of tools within sections were correctly maintained. But the newly added labels didn't appear and the added label lines disappeared in integrated_tool_panel.xml file. Please help me in correctly adding labels to the installed tools for a local Galaxy. Thank you very much. Qiaoping

ADD COMMENTlink modified 14 months ago by Hotz, Hans-Rudolf1.7k • written 14 months ago by qyuan30
0
gravatar for Hotz, Hans-Rudolf
14 months ago by
Switzerland
Hotz, Hans-Rudolf1.7k wrote:

Hi Qiaoping

The "integrated_tool_panel.xml" file is generated based on the information in config/tool_conf.xml and config/shed_tool_conf.xml. Add the labels there.

Though, in order to get all the changes, it sometimes help, to remove "integrated_tool_panel.xml" (or just rename it in order to be on the safe side) before you restart Galaxy.

Regards, Hans-Rudolf

ADD COMMENTlink written 14 months ago by Hotz, Hans-Rudolf1.7k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 102 users visited in the last hour