Question: homer installaton from tool shed
0
gravatar for balaszone
2.1 years ago by
balaszone60
balaszone60 wrote:

Hello,

I'm running a galaxy local instance in my computer. I'm trying to install homer from tool shed. Although it looks it installed all the required applications, I'm not able to run the command successfully via galaxy. "manage installed tools" section shows the status as "INstalled - but missing some dependencies" . I even tried installing all 3 version from different contirbutors available in tool shed. but none seem to work. In specific, I'm trying to run the command maketagdirectory but with no luck.

any help?

THanks, Bala

homer atac galaxy • 699 views
ADD COMMENTlink modified 13 months ago by Martin Čech ♦♦ 4.8k • written 2.1 years ago by balaszone60

Hello Bala,

After you installed your local Galaxy, did you set the directory for tool dependancies? If not, see the 'Set the Directory for Tool Dependencies' section of the wiki: https://wiki.galaxyproject.org/Admin/Tools/AddToolFromToolShedTutorial

If you have not, go ahead and make a home for your dependencies and then 'repair repository' of the incompletely loaded tools.

Cheers,

Mo Heydarian, Galaxy Team

ADD REPLYlink written 2.1 years ago by Mo Heydarian820
1
gravatar for Martin Čech
13 months ago by
Martin Čech ♦♦ 4.8k
United States
Martin Čech ♦♦ 4.8k wrote:

the homer tool repository says in the readme

Currently only some tools have been wrapped. Contact me if you want to contribute.

and in the tool_dependencies.xml it says

I'm sorry but this does not work

So this tool does not seem ready to be deployed - it needs some development time. I suggest contacting the IUC (https://gitter.im/galaxy-iuc/iuc) and asking for help.

ADD COMMENTlink written 13 months ago by Martin Čech ♦♦ 4.8k

Everything worked out for me, i just had to replace :

$SHEDTOOLSDIR/shed_tools/toolshed.g2.bx.psu.edu/repos/iuc/package_ghostscript_9_07/641d51248b4b/package_ghostscript_9_07/tool_dependencies.xml Line 12 :

<action type="download_by_url" sha256sum="44800d004c53f13192d1b5db413119198ddfc8a11c4d2a030aac2f2fda822ebf">https://depot.galaxyproject.org/software/ghostscript/ghostscript_9.07_src_all.tar.gz</action>

and :

$SHEDTOOLSDIR/shed_tools/toolshed.g2.bx.psu.edu/repos/chseward/homer_47/9764a14c8e3a/homer_47/tool_dependencies.xml Line 18 :

<action type="download_by_url">http://homer.ucsd.edu/homer/data/software/homer.v4.9.zip</action>

then hit "repair" on each package in the admin interface.

Cheers, Laurent.

ADD REPLYlink modified 13 months ago • written 13 months ago by laurent.fournier10
0
gravatar for laurent.fournier
13 months ago by
GIGA Research Center
laurent.fournier10 wrote:

Hello,

I actually ran into the same issue, even with toolshed configured correctly it do not work.

This appens because the archives downloaded to install homer AND one of it's dependencies (ghostscript) do not exist anymore therefore we got to theses error messages.

Anyone have found a solution yet ?

Cheers, Laurent Fournier.

ADD COMMENTlink written 13 months ago by laurent.fournier10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 97 users visited in the last hour