Question: Error in new galaxy install
0
gravatar for djevo1
20 months ago by
djevo160
djevo160 wrote:

I setup a fresh install of the latest stable galaxy and am not getting this error when I try to login. I am the only user on this setup and there is no data. I cannot login either.

"onLine": true,
  "version": "17.05",
  "xhr": {
    "readyState": 4,
    "responseText": "{\"err_msg\": \"History is not accessible by user\", \"err_code\": 403002}",
    "responseJSON": {
      "err_msg": "History is not accessible by user",
      "err_code": 403002
    },
    "status": 403,
    "statusText": "Forbidden"


},
  "options": {
    "parse": true,
    "keys": "type_id,element_count",
    "filters": {
      "history_content_type": "dataset_collection"
    },
    "remove": false,
    "traditional": true,
    "data": {
      "keys": "type_id,element_count",
      "order": "hid",
      "v": "dev",
      "q": [
        "history_content_type",
        "deleted",
        "purged",
        "visible"
      ],
      "qv": [
        "dataset_collection",
        "False",
        "False",
        "True"
      ]
    },
    "emulateHTTP": false,
    "emulateJSON": false,
    "textStatus": "error",
    "errorThrown": "Forbidden"
  },
error galaxy • 562 views
ADD COMMENTlink modified 20 months ago by Dannon Baker3.7k • written 20 months ago by djevo160
0
gravatar for Dannon Baker
20 months ago by
Dannon Baker3.7k
United States
Dannon Baker3.7k wrote:

This sounds very familiar to a bug we just encountered today doing some debugging. If you 'name' the history, does this still happen?

I'm working on a fix, but setting a history name and saving it may be a temporary workaround.

ADD COMMENTlink written 20 months ago by Dannon Baker3.7k

I can name a history as an anonymous user, but I cannot login and name a history.

ADD REPLYlink modified 20 months ago • written 20 months ago by djevo160

I can also not name a history as an anonymous user either.

ADD REPLYlink written 20 months ago by djevo160

This is an issue in the production release. I just re-downloaded the code and restarted galaxy with the same issue.

ADD REPLYlink written 20 months ago by djevo160
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 131 users visited in the last hour