Question: Workflow download seems not to work (Root cause missing user name, see reply for issue tracking ticket)
1
gravatar for mkrause
8 months ago by
mkrause10
mkrause10 wrote:

Hi Community. I want to export a workflow created for a course. However, either I do not find the right place, or Exporting workflows does not work.

I made a workflow and go on the tab "workflows" to find it. Then I open the menu list and go to "share and download". There I choose "Download" as I just want to have a file to be examined by the course officials.

However, whenever I click on download, an error message occures. Please find below

Not Found The resource could not be found. No route for /u/w/coursera-course-galaxy/json-download

Can anybody give me advice? Thanks

workflow galaxy export • 252 views
ADD COMMENTlink modified 7 months ago by Jennifer Hillman Jackson22k • written 8 months ago by mkrause10
0
gravatar for Dannon Baker
7 months ago by
Dannon Baker3.6k
United States
Dannon Baker3.6k wrote:

Hrmm. That link doesn't look quite right, it should be something like:

https://usegalaxy.org/u/dannonbaker/w/unnamed-workflow-3/json-download

Note the 'dannonbaker' between the 'u' and 'w' sections. That should be your galaxy public username, which, looking at your profile, is not set. If you set a username in your preferences, it'll work.

Sorry for this bug -- it should not be possible to have an empty username since things like this rely on it, and there's a ticket here that I've subscribed to and will follow up on a solution for: https://github.com/galaxyproject/galaxy/issues/1404

ADD COMMENTlink modified 7 months ago • written 7 months ago by Dannon Baker3.6k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 55 users visited in the last hour