Question: Egg 'pexpect' not fetchable
0
gravatar for BuysDB
4.4 years ago by
BuysDB • 10
Netherlands
BuysDB • 10 wrote:

Hi, I installed Galaxy and configured it to run jobs on our (SGE) cluster using drmaa. The following error occurs when running a tool (select random lines):

Traceback (most recent call last):
  File "./scripts/set_metadata.py", line 31, in <module>
    import galaxy.model.mapping  # need to load this before we unpickle, in order to setup properties assigned by the mappers
  File "/opt/apps-galaxy/dev-20140715/galaxy-dist/lib/galaxy/model/__init__.py", line 9, in <module>
    eggs.require("pexpect")
  File "/opt/apps-galaxy/dev-20140715/galaxy-dist/lib/galaxy/eggs/__init__.py", line 424, in require
    raise EggNotFetchable( str( [ egg.name for egg in e.eggs ] ) )
galaxy.eggs.EggNotFetchable: ['pexpect']

I suspected that the egg wouldn't be in the egg directory, but it is:

[galaxy-dev@z eggs]$ ls ./eggs | grep pexpect 
pexpect-2.4-py2.7.egg

The egg is downloaded again when I remove it.

The cluster job does produce output in the job_working_directory, and the output dataset is moved to the database/files. However the dataset in Galaxy is in error state so it cannot be used further from the Galaxy interface. I am wondering what I should configure to fix this.

Thanks.

egg sge galaxy • 1.3k views
ADD COMMENT • link • modified 4.4 years ago • written 4.4 years ago by BuysDB • 10
2
gravatar for BuysDB
4.4 years ago by
BuysDB • 10
Netherlands
BuysDB • 10 wrote:

Solution:

I used galaxy-dist (5273e0bf9ae5) when the error occurred. I installed galaxy-central (646c414e9051) and just copied my configuration files and it runs without the errors mentioned in my question, so it seems there is a bug in galaxy-dist (5273e0bf9ae5).

Correction: it is caused by using Python 2.7.3, switching to 2.6.6 solved the problem. (It causes Galaxy to download different eggs).

ADD COMMENT • link modified 4.4 years ago • written 4.4 years ago by BuysDB • 10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 172 users visited in the last hour