Question: Job is waiting to run.
1
gravatar for kirby.ziegler
4.0 years ago by
kirby.ziegler10 wrote:

Hello, 

I have been trying to run a Bowtie job(s) for two full days and they just hang with the "waiting to run" status? Is there a backend issue with my account?

K

queue jobs bowtie • 3.5k views
ADD COMMENTlink modified 4.0 years ago by damcpher0 • written 4.0 years ago by kirby.ziegler10

I let one sit for a full day. I have stopped and deleted them a few times and have tried different things to get it to work. ie purging my deleted files.

ADD REPLYlink written 4.0 years ago by kirby.ziegler10

Jobs taking around a day is not unusual at peak times. However, if they were in a "blue" hold (instead of "grey" waiting) state, then permanently deleting other datasets to make room for new work is the solution. You do not need to stop running jobs to do this. Job and disk quotas are listed with advice in this wiki:
https://wiki.galaxyproject.org/Main

Deleting and restarting jobs does take up some resource and can cause delays, but most likely the biggest delay the second time is that you just entered the queue at the end again. If you now have room for the work, permit the jobs to run to completion.

Best, Jen, Galaxy team

ADD REPLYlink written 4.0 years ago by Jennifer Hillman Jackson24k

Other jobs run, but the bowtie does not.

ADD REPLYlink written 4.0 years ago by kirby.ziegler10

There are different queues for different types of jobs. Permit these to run and all should be fine.

ADD REPLYlink written 4.0 years ago by Jennifer Hillman Jackson24k

I've been experiencing the same difficulty. My Bowtie jobs aren't running. Is there anywhere that Galaxy provides an estimate of what time you will get your data based on your position in the queue?

ADD REPLYlink written 4.0 years ago by damcpher0

There is none yet although there are some plans on providing this information. To obtain this information is quite complex and the results are unreliable so the motivation is not the highest.

ADD REPLYlink written 4.0 years ago by Martin Čech ♦♦ 4.6k
1
gravatar for Jennifer Hillman Jackson
4.0 years ago by
United States
Jennifer Hillman Jackson24k wrote:

Hello,

This is at http://usegalaxy.org (Main)?

The job queue is busy but two days seems like a long time. Did you by chance stop and restart the jobs? Or did you have other jobs queued (in other histories will count as well) before these? Jobs run in the order submitted, in turn with other users on the instance.

https://wiki.galaxyproject.org/Support#Dataset_status_and_how_jobs_execute

If you continue to have problems, please send a shared history link with your galaxy user email to galaxy-bugs@bx.psu.edu and we can look into this further.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 4.0 years ago by Jennifer Hillman Jackson24k

Hi Jen, I am actually having the exact same issue at usegalaxy.org. 

I have been trying to run bowtie jobs but they are been grey 'waiting to run' for almost 24 hours now. I have not stopped or re-submitted them at all, as to not disrupt my place in the queue. These are my only jobs in my history waiting to run. Thanks for any advice or insight you can provide. 

ADD REPLYlink written 4.0 years ago by fat90

Thanks for additional feedback. We are checking again on the current status on the queue that runs NGS jobs, but it is most likely just busy. If there is anything different going on, we'll post an update.

Thanks! Jen, Galaxy team

ADD REPLYlink written 4.0 years ago by Jennifer Hillman Jackson24k

Hi Jan,

I am a new user of Galaxy server. I just configured the Galaxy server on my local machine and submitted some jobs. However, no job is running and the status says "This job is waiting to run" only but no progress etc.

Please note that I am running it on Ubuntu 14.04 and using the latest codes downloaded from the GitHub.

Regards,

Reza

 

ADD REPLYlink written 2.3 years ago by asif.karim.csedu10

Please create a new question instead of resurrecting this thread, thanks.

ADD REPLYlink written 2.3 years ago by Martin Čech ♦♦ 4.6k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 69 users visited in the last hour