Question: Installing Galaxy With Apache ...
0
gravatar for Neil.Burdett@csiro.au
6.3 years ago by
Neil.Burdett@csiro.au • 310 wrote:
Hi I've installed galaxy with the default settings and it works fine. On a new Ubuntu machine I am trying to get galaxy running with Apache. But I am having problems, I've followed the documentation. After installing Apache I can put my ip address into a browser and I get message saying Apache is working fine. It displays a message from /var/www/index.html Now when I start galaxy I was assuming I would get redirected to the galaxy welcome page, but this doesn't happen and it remains at /var/www/index.html. To view the welcome page I have to add ":8080" after the ip address. Is this still required? I thought that Apache would know to redirect to my distribution....What am I doing wrong? /etc/apache2/sites-available/default-ssl and /etc/apache2/sites- available/default look like this ... DocumentRoot /var/www <directory/> Options FollowSymLinks AllowOverride None </directory> <directory var="" www=""/> Options Indexes FollowSymLinks MultiViews AllowOverride None Order allow,deny allow from all </directory> etc ... /var/www/.htaccess RewriteEngine on RewriteRule ^/galaxy$ /galaxy/ [R] RewriteRule ^/galaxy/static/style/(.*) /home/galaxy/galaxy- dist/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy/static/scripts/(.*) /home/galaxy/galaxy- dist/static/scripts/packed/$1 [L] RewriteRule ^/galaxy/static/(.*) /home/galaxy/galaxy-dist/static/$1 [L] RewriteRule ^/galaxy/favicon.ico /home/galaxy/galaxy- dist/static/favicon.ico [L] RewriteRule ^/galaxy/robots.txt /home/galaxy/galaxy- dist/static/robots.txt [L] RewriteRule ^/galaxy(.*) http://localhost:8080$1 [P] I created an empty 'galaxy' directory with 777 permissions on it under /var/www and universe_wsgi.ini # Define the proxy-prefix filter. [filter:proxy-prefix] use = egg:PasteDeploy#prefix prefix = /galaxy # ---- Galaxy --------------------------------------------------------------- # Configuration of the Galaxy application. [app:main] filter-with = proxy-prefix cookie_path = /galaxy Thanks Neil
galaxy • 7.8k views
ADD COMMENT • link • modified 6.3 years ago by Jelle Scholtalbers • 360 • written 6.3 years ago by Neil.Burdett@csiro.au • 310
0
gravatar for Jelle Scholtalbers
6.3 years ago by
Germany
Jelle Scholtalbers • 360 wrote:
Hi Neil, with your current apache configuration, you should probably see Galaxy at http://yourip/galaxy This is due to your Rewriterule /galaxy and for that you have also set proxy_prefix = /galaxy in your universe_wsgi.ini You should probably remove the empty galaxy directory under /var/www Furthermore, most of the time you will not need a directory with 777 in your apache web/documentroot.. Cheers, Jelle
ADD COMMENT • link written 6.3 years ago by Jelle Scholtalbers • 360
Hi Jelle, I'm still having issues with Apache. I've moved RewriteEngine on RewriteRule ^/galaxy$ /galaxy/ [R] RewriteRule ^/galaxy/static/style/(.*) /home/galaxy/galaxy- dist/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy/static/scripts/(.*) /home/galaxy/galaxy- dist/static/scripts/packed/$1 [L] RewriteRule ^/galaxy/static/(.*) /home/galaxy/galaxy-dist/static/$1 [L] RewriteRule ^/galaxy/favicon.ico /home/galaxy/galaxy- dist/static/favicon.ico [L] RewriteRule ^/galaxy/robots.txt /home/galaxy/galaxy- dist/static/robots.txt [L] RewriteRule ^/galaxy(.*) http://localhost:8080$1 [P] from /var/www/.htaccess to /etc/apache2/httpd.conf I still get a "404 Not found" error when trying to access galaxy (http://140.253.78.44/galaxy ) http://140.253.78.44 still gets the "It Works!" Apache default index.html and http://140.253.78.44:8080 gets the galaxy page /var/log/apache2/error.log states... [Fri Aug 24 07:35:27 2012] [error] [client 140.253.78.44] File does not exist: /var/www/favicon.ico [Fri Aug 24 07:36:25 2012] [error] [client 140.253.78.44] File does not exist: /var/www/galaxy Now if I change httpd.conf and add the vitrtualHost tags to: ServerName localhost <virtualhost *:80=""> RewriteEngine on RewriteRule ^/galaxy$ /galaxy/ [R] RewriteRule ^/galaxy/static/style/(.*) /home/galaxy/galaxy- dist/static/june_2007_style/blue/$1 [L] RewriteRule ^/galaxy/static/scripts/(.*) /home/galaxy/galaxy- dist/static/scripts/packed/$1 [L] RewriteRule ^/galaxy/static/(.*) /home/galaxy/galaxy-dist/static/$1 [L] RewriteRule ^/galaxy/favicon.ico /home/galaxy/galaxy- dist/static/favicon.ico [L] RewriteRule ^/galaxy/robots.txt /home/galaxy/galaxy- dist/static/robots.txt [L] RewriteRule ^/galaxy(.*) http://localhost:8080$1 [P] </virtualhost> I now get a "403 Forbidden" error when trying to access (http://140.253.78.44/galaxy ) You don't have permission to access /galaxy/ on this server, and /var/log/apache2/error.log states.. [Fri Aug 24 07:45:33 2012] [error] [client 140.253.78.44] attempt to make remote request from mod_rewrite without proxy enabled: proxy:http://localhost:8080/ [Fri Aug 24 07:45:34 2012] [error] [client 140.253.78.44] File does not exist: /etc/apache2/htdocs Any help much appreciated Neil ________________________________________ To: Burdett, Neil (ICT Centre, Herston - RBWH) Cc: galaxy-user@lists.bx.psu.edu Subject: Re: [galaxy-user] Installing galaxy with Apache ... Hi Neil, with your current apache configuration, you should probably see Galaxy at http://yourip/galaxy This is due to your Rewriterule /galaxy and for that you have also set proxy_prefix = /galaxy in your universe_wsgi.ini You should probably remove the empty galaxy directory under /var/www Furthermore, most of the time you will not need a directory with 777 in your apache web/documentroot.. Cheers, Jelle
ADD REPLY • link written 6.3 years ago by Neil.Burdett@csiro.au • 310
Hi Neil, I'm certainly not an apache expert so I might be giving you the wrong advise, but try adding the following: LoadModule proxy_module modules/mod_proxy.so LoadModule proxy_http_module modules/mod_proxy_http.so If above fails, try to go back to the simplest configuration mentioned on the galaxy wiki: http://wiki.g2.bx.psu.edu/Admin/Config/Apache%20Proxy Thus: RewriteEngine on RewriteRule ^(.*) http://localhost:8080$1 [P] Which would make your galaxy instance available on http://yourip Cheers, Jelle
ADD REPLY • link written 6.3 years ago by Jelle Scholtalbers • 360
This thread my help you: http://dev.list.galaxyproject.org/Running-Galaxy-behind- apache2-td4624545.html
ADD REPLY • link written 6.3 years ago by Carlos Borroto • 390
Thanks very much. This did in fact solve the issue. For those following the thread the "Rewrite" statements have to be added to /etc/apache2/sites-available/defaults. Thanks Again Neil To: Burdett, Neil (ICT Centre, Herston - RBWH) Cc: galaxy-user@lists.bx.psu.edu Subject: Re: [galaxy-user] Installing galaxy with Apache ... This thread my help you: http://dev.list.galaxyproject.org/Running-Galaxy-behind- apache2-td4624545.html
ADD REPLY • link written 6.3 years ago by Neil.Burdett@csiro.au • 310
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 182 users visited in the last hour