Question: Installation TTW throws python error, remains in "cloning" stage
0
gravatar for lachlan.simpson
7 days ago by
lachlan.simpson20 wrote:

Galaxy 18.05 on CentOS 7.5

Some tools, when I try to install them through the web, will get stuck on one tool in the "cloning" state.

In the galaxy/uwsgi.log I see this:

10.126.160.102 - - [11/Sep/2018:13:44:34 +1100] "POST /galaxy/admin_toolshed/install_repositories HTTP/1.1" 500 - "https://company.com/galaxy/admin_toolshed/browse_toolsheds" "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0"
Error - <type 'exceptions.AttributeError'="">: 'NoneType' object has no attribute 'endswith'
URL: https://company.com/galaxy/admin_toolshed/install_repositories
File 'lib/galaxy/web/framework/middleware/error.py', line 154 in __call__
  app_iter = self.application(environ, sr_checker)
File '/galaxy/development/.venv/lib/python2.7/site-packages/paste/recursive.py', line 85 in __call__
  return self.application(environ, start_response)
File '/galaxy/development/.venv/lib/python2.7/site-packages/paste/httpexceptions.py', line 640 in __call__
  return self.application(environ, start_response)
File 'lib/galaxy/web/framework/base.py', line 142 in __call__
  return self.handle_request(environ, start_response)
File 'lib/galaxy/web/framework/base.py', line 221 in handle_request
  body = method(trans, **kwargs)
File 'lib/galaxy/web/framework/decorators.py', line 98 in decorator
  return func(self, trans, *args, **kwargs)
File 'lib/galaxy/webapps/galaxy/controllers/admin_toolshed.py', line 575 in install_repositories
  reinstalling=reinstalling,
File 'lib/tool_shed/galaxy_install/install_manager.py', line 846 in install_repositories
  tool_panel_section_mapping=tool_panel_section_mapping)
File 'lib/tool_shed/galaxy_install/install_manager.py', line 872 in install_tool_shed_repository
  install_dir = os.path.join(tool_path, relative_install_dir)
File '/galaxy/development/.venv/lib64/python2.7/posixpath.py', line 77 in join
  elif path == '' or path.endswith('/'):
AttributeError: 'NoneType' object has no attribute 'endswith'

Have I made a mistake in my Galaxy installation process? I've got a long list of tools successfully installed - it's only installing new tools.

I've experienced this problem installing: rgrnastar, zerone, suite_gops_1_0.

ADD COMMENTlink modified 6 days ago by Jennifer Hillman Jackson25k • written 7 days ago by lachlan.simpson20
0
gravatar for Jennifer Hillman Jackson
6 days ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

This has been reported by another user recently. They installed through the command-line instead. Details here: https://biostar.usegalaxy.org/p/29278/

We should let the developers know about the problem. I started the conversation at Gitter here, please join in and add details/followup to complete the troubleshooting: https://gitter.im/galaxyproject/Lobby?at=5b981a57f3c26b08f661c128

Thanks! Jen, Galaxy team

ADD COMMENTlink written 6 days ago by Jennifer Hillman Jackson25k

Thanks Jen - I've already tried that (the other user is me). This was the result of searching the logs while trying to work out why suite_gops wasn't installing.

ADD REPLYlink written 6 days ago by lachlan.simpson20

Oh sorry, I missed that! Next time let's keep the same issue in the same post until fully resolved.

The feedback today at Gitter was to make sure the tool install directory was properly configured. However, it doesn't sound like that is your problem given that other tools have installed correctly. So, reply at Gitter with your followup to determine if there is some other configuration troubleshooting that can be done -- or -- if there is Galaxy problem that hasn't been characterized yet/fixed.

We are freezing the next release very soon and reporting problems now would be important if any changes to the distribution are needed/priority. We all appreciate this type of feedback!

ADD REPLYlink written 6 days ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 151 users visited in the last hour