Question: Bam filter does not work the way I expect
0
gravatar for anamabrantesc
3 months ago by
anamabrantesc0 wrote:

I am having difficulty with NGS: Bam Filter tools. The condition that appear in the resulting JSON filter rules are not the conditions I chose, and the resulting reads are not the ones I want. For instance using

{
    "filters": [
        {
            "mapQuality": ">=15", 
            "id": "1"
        }, 
        {
            "isMapped": "true", 
            "id": "2"
        }, 
        {
            "isMateMapped": "true", 
            "id": "3"
        }
    ]
}

I get many reads with mapq = 0... What am I doing wrong?

condition rules filter bam • 117 views
ADD COMMENTlink modified 3 months ago by Jennifer Hillman Jackson25k • written 3 months ago by anamabrantesc0
0
gravatar for Jennifer Hillman Jackson
3 months ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

"Conditions" are evaluated separately during the filter. Two choices:

  • Nest all of the Filters under the same Condition on the tool form. This is the most straightforward usage for your case.
  • Build a rule for the evaluation of the different Condition filters. How-to is described in one of the tool form examples.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 3 months ago by Jennifer Hillman Jackson25k

I ran a few tests and think the "rule" option is problematic right now. So, just nest the Filters for now. Also, there are server BAM filter tools on the server if this one doesn't do quite what you want.

If interested, the BamTools BAM Filter rule problem is ticketed here: https://github.com/galaxyproject/usegalaxy-playbook/issues/116

ADD REPLYlink written 3 months ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 108 users visited in the last hour