Question: problem with "join" tool
1
gravatar for annabahleda
12 months ago by
annabahleda10
annabahleda10 wrote:

Dear All,

I've got problem with "join" tool. When I'm trying to combine two datasets, I obtain this message

Traceback (most recent call last): File "/home/ubuntu/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/join/a10f49d9218a/join/gops_join.py", line 20, in <module> from galaxy.tools.util.galaxyops import fail, parse_cols_arg, skipped ImportError: No module named galaxy.tools.util.galaxyops

What should I do?

Best, Anna

ngs • 253 views
ADD COMMENTlink modified 12 months ago by Jennifer Hillman Jackson25k • written 12 months ago by annabahleda10
0
gravatar for Jennifer Hillman Jackson
12 months ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

I see the problem. Installing into Galaxy version 17.09 (just released today). The GOBS suite installs tools but under Admin > Manage installed tools, those that failed to install dependencies are noted. In this case - this tool suite, all with that problem are marked with a red arrow indicating that a newer tool version is available. For each with that designation, click on the tool and select "Install latest revision".

That cleared up dependency problems in my test instance and should in yours as well.

I may open a ticket for this, but need to check if an update is already planned or not yet for this repo already. I didn't want to wait to give you a workaround solution now and this is not the only tool that might require some extra steps after install. It is a good practice to review how tool installs finish up (the state) and to check for tool updates.

Thanks for reporting the problem! Jen, Galaxy team

ADD COMMENTlink written 12 months ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 135 users visited in the last hour