Question: galaxy start error
1
gravatar for yychangsd
11 months ago by
yychangsd30
yychangsd30 wrote:

I installed a local galaxy and start it successfully.

Then I'd like to add some pipelines into my local galaxy.

It was running well.

I'd like to shut down and re-start it and got an error like this:

Activating virtualenv at .venv
Requirement already satisfied: pip>=8.1 in ./.venv/lib/python2.7/site-packages
Requirement already satisfied: bx-python==0.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 2))
Requirement already satisfied: MarkupSafe==0.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3))
Requirement already satisfied: PyYAML==3.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4))
Requirement already satisfied: SQLAlchemy==1.0.15 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5))
Requirement already satisfied: mercurial==3.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 6))
Requirement already satisfied: numpy==1.9.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7))
Requirement already satisfied: pycrypto==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8))
Requirement already satisfied: Paste==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 15))
Requirement already satisfied: PasteDeploy==1.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16))
Requirement already satisfied: docutils==0.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17))
Requirement already satisfied: wchartype==0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18))
Requirement already satisfied: repoze.lru==0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19))
Requirement already satisfied: Routes==2.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20))
Requirement already satisfied: WebOb==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21))
Requirement already satisfied: WebHelpers==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22))
Requirement already satisfied: Mako==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23))
Requirement already satisfied: pytz==2015.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24))
Requirement already satisfied: Babel==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25))
Requirement already satisfied: Beaker==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26))
Requirement already satisfied: dictobj==0.3.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27))
Requirement already satisfied: nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 28))
Requirement already satisfied: Parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 29))
Requirement already satisfied: six==1.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30))
Requirement already satisfied: Whoosh==2.7.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31))
Requirement already satisfied: testfixtures==4.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 32))
Requirement already satisfied: galaxy_sequence_utils==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 33))
Requirement already satisfied: Cheetah==2.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36))
Requirement already satisfied: Markdown==2.6.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37))
Requirement already satisfied: bioblend==0.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40))
Requirement already satisfied: boto==2.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41))
Requirement already satisfied: requests==2.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42))
Requirement already satisfied: requests-toolbelt==0.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 43))
Requirement already satisfied: kombu==3.0.30 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46))
Requirement already satisfied: amqp==1.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47))
Requirement already satisfied: anyjson==0.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48))
Requirement already satisfied: psutil==4.1.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51))
Requirement already satisfied: pulsar-galaxy-lib==0.7.0.dev5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52))
Requirement already satisfied: sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 55))
Requirement already satisfied: decorator==4.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 56))
Requirement already satisfied: Tempita==0.5.3dev in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57))
Requirement already satisfied: sqlparse==0.1.16 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58))
Requirement already satisfied: pbr==1.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59))
Requirement already satisfied: svgwrite==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 62))
Requirement already satisfied: pyparsing==2.1.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 63))
Requirement already satisfied: Fabric==1.10.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66))
Requirement already satisfied: paramiko==1.15.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 67))
Requirement already satisfied: ecdsa==0.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 68))
Requirement already satisfied: pysam==0.8.4+gx5 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 71))
Requirement already satisfied: PasteScript in ./.venv/lib/python2.7/site-packages (from pulsar-galaxy-lib==0.7.0.dev5->-r requirements.txt (line 52))
Requirement already satisfied: MySQL-python in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 1))
Activating virtualenv at .venv
galaxy.tools.deps DEBUG 2017-06-30 11:07:29,833 Unable to find config file './dependency_resolvers_conf.xml'
galaxy.tools.deps.resolvers.conda WARNING 2017-06-30 11:07:29,835 Conda install prefix '/home/oasis/gordon-data/galaxy-17.01/database/dependencies/_conda' is 65 characters long, this can cause problems with package installation, consider setting a shorter prefix (conda_prefix in galaxy.ini)
galaxy.tools.deps.conda_util INFO 2017-06-30 11:07:29,844 Installing Conda, this may take several minutes.
/bin/sh: /home/oasis/gordon-data/galaxy-17.01/database/dependencies/_conda/bin/conda: No such file or directory
galaxy.tools.deps.installable WARNING 2017-06-30 11:07:29,909 Conda installation requested and failed.
galaxy.tools.deps.resolvers.conda WARNING 2017-06-30 11:07:29,910 Conda install prefix '/home/oasis/gordon-data/galaxy-17.01/database/dependencies/_conda' is 65 characters long, this can cause problems with package installation, consider setting a shorter prefix (conda_prefix in galaxy.ini)
galaxy.tools.deps.conda_util INFO 2017-06-30 11:07:29,913 Installing Conda, this may take several minutes.
/bin/sh: /home/oasis/gordon-data/galaxy-17.01/database/dependencies/_conda/bin/conda: No such file or directory
galaxy.tools.deps.installable WARNING 2017-06-30 11:07:29,980 Conda installation requested and failed.
Entering daemon mode

Any suggestions would be greatly appreciated~~

galaxy • 325 views
ADD COMMENTlink modified 10 months ago by danielsauceda60 • written 11 months ago by yychangsd30

Update me if I am right please

ADD REPLYlink written 10 months ago by danielsauceda60

Yes, uncommenting this line the galaxy.ini file is how to have the non-sample config file recognized/utilized.

Thanks for posting back your solution! Jen, Galaxy team

ADD REPLYlink written 10 months ago by Jennifer Hillman Jackson25k
1
gravatar for danielsauceda
10 months ago by
Texas A&M
danielsauceda60 wrote:

I know what it is. in the initial clone of galaxy there is file called config/dependency_resolvers_conf.xml.sample if you change the name of this file to be config/dependency_resolvers_conf.xml

you will get the error shown below

galaxy.tools.deps DEBUG 2017-06-30 11:07:29,833 Unable to find config file './dependency_resolvers_conf.xml

in side your galaxy.ini you need uncomment the line so that galaxy know what to look for

#dependency_resolvers_config_file = config/dependency_resolvers_conf.xml

ADD COMMENTlink modified 10 months ago • written 10 months ago by danielsauceda60
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 134 users visited in the last hour