Question: On executing SnpEff n a Galaxy cloud instance we have the error: All frames are zero
0
gravatar for msprindzhuk
14 months ago by
msprindzhuk40
msprindzhuk40 wrote:

On executing SnpEff we have the following error:

WARNING: All frames are zero! This seems rather odd, please check that 'frame' information in your 'genes' file is accurate. java.lang.RuntimeException: Most Exons do not have sequences! at ca.mcgill.mcb.pcingola.snpEffect.factory.SnpEffPredictorFactoryGff.create(SnpEffPredictorFactoryGff.java:129) at ca.mcgill.mcb.pcingola.snpEffect.commandLine.SnpEffCmdBuild.createSnpEffPredictor(SnpEffCmdBuild.java:104) at ca.mcgill.mcb.pcingola.snpEffect.commandLine.SnpEffCmdBuild.run(SnpEffCmdBuild.java:284)

How to fix that? Thank you.

snpeff • 358 views
ADD COMMENTlink modified 14 months ago by Jennifer Hillman Jackson25k • written 14 months ago by msprindzhuk40
0
gravatar for Jennifer Hillman Jackson
14 months ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

This appears to be a data problem from the error message. Check the content of the reference annotation and correct it to work with this tool.

I also suggest checking the input BAM dataset to ensure expected mapping rates and checking that the reference annotation is a match for the target reference genome. You could also try visualizing (at UCSC, IGV, etc) for a few target genes to help determine what the exact issue is.

Does this mean that the configuration issues for this tool are now resolved? If so, please post back with a comment on this thread https://biostar.usegalaxy.org/p/21962/ and we can close it out. If you want to share what the issue was and how you resolved it, that can be helpful information for others.

Thanks, Jen, Galaxy team

ADD COMMENTlink written 14 months ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 103 users visited in the last hour