Question: Workflow sharing menu not working
0
gravatar for fiebig
15 months ago by
fiebig30
fiebig30 wrote:

Hello,

I have serious problems to download, view or export workflows of my local 16.04 instance. The "Download" and "Create SVG" buttons simply do not work - no error message here. The "View" problem returns the following error:

Module cgi:1034 in escape

s = s.replace("&", "&") # Must be done first! AttributeError: 'NoneType' object has no attribute 'replace'

Originally, the workflows were transferred from my old local instance (15.10) and all of the sharing features have worked well in the old instance.

Any suggestions here? It would be great to use the missing functions. Furthermore I can't include the workflow in the galaxy pages for creating tutorials.

Anne

ADD COMMENTlink modified 15 months ago by Dannon Baker3.7k • written 15 months ago by fiebig30
0
gravatar for Dannon Baker
15 months ago by
Dannon Baker3.7k
United States
Dannon Baker3.7k wrote:

Hey, I'm happy to take a look at this.

Can you share 1) a minimal workflow that reproduces this and 2) what revision of Galaxy you're using exactly? Is it the most up-to-date 16.04, or perhaps a bit out of date?

ADD COMMENTlink written 15 months ago by Dannon Baker3.7k

Hi Dannon, I glad you can afford some time for the problem. 2) The instance was installed on June 26 - so its, not that old. I hope this helps with the versions. 1) The actual worklflow contains several of my own scripts, but I have set up a small workflow, which is also part of "full" workflow. It contains only tools from toolshed - just to be sure, that my own tools do not cause the problem. I can view the workflow, but still the both export buttons ("Export" and "Create") do not work. Here is the workflow:

  • Step 1: Input dataset collection (->a bunch of raw fastqs)
  • Step 2: Cutadapt (->clip the reads)
  • Step 3: Select (->extract some lines)
  • Select lines from Output dataset 'report' from step 2 that Matching the pattern ^.Processed.$
  • Step 4: Collapse Collection (->join them to recieve a small statistics file)

Yesterday I also took a look into database. In the "workflow_step" table three columns (tool_errors, position, config) differ between my two instances. a) old 15.10 instance usinf sqlite

1282|2016-08-25 15:06:52.744532|2016-08-25 15:06:52.744539|142|tool|gbs_gen_call_py|1.0.0|{"chet": "\"3\"", "chom": "\"1\"", "f": "\"0.05\"", "h": "\"0.1\"", "m": "\"0.9\"", "qhet": "\"5\"", "qhom": "\"3\"", "qual": "\"40\"", "vcf_in": "null"}||{"left": 833.5, "top": 239.5}||5||b77ed01be1564068a9b5c9783b375a12

b) 16.04 instance using postgres

6|2016-06-29 13:51:30.541828|2016-06-29 13:51:30.541843|1|tool|gbs_gen_call_py|1.0.0|\x7b2263686574223a20225c22335c22222c202263686f6d223a20225c22315c22222c202266223a20225c22302e30355c22222c202268223a20225c22302e315c22222c20226d223a20225c22302e395c22222c202271686574223a20225c22355c22222c202271686f6d223a20225c22335c22222c20227175616c223a20225c2234305c22222c20227663665f696e223a20226e756c6c227d||\x7b226c656674223a203838382e352c2022746f70223a203431342e357d||5||b77ed01be1564068a9b5c9783b375a12

Ok, this might be due to the dirrent DBs...(I'm not familiar with Postgres)

Regards,

Anne

ADD REPLYlink modified 15 months ago • written 15 months ago by fiebig30
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 91 users visited in the last hour