Question: Galaxy Install Issues - Pysam
gravatar for njoebott
9 months ago by
njoebott30 wrote:

This is in regards to a local install deployment on CentOS 7 with Python 2.7.5 - an update and a question.

In order to get the & common_startup scripts to work I had to modify the common_startup to prevent SSL issues:

: ${GALAXY_WHEELS_INDEX_URL:=""} <--changed this from https to http

if [ $REPLACE_PIP -eq 1 ]; then pip install 'pip>=8.1' fi

Added this -> : ${GALAXY_TRUST_HOST:=""}

if [ $FETCH_WHEELS -eq 1 ]; then pip install -r requirements.txt --extra-index-url ${GALAXY_WHEELS_INDEX_URL} --trusted-host ${GALAXY_TRUST_HOST} <--Added this

This is effectively allows you to do install the with following command line: pip install --upgrade --extra-index-url --trusted-host <package>

This works until you get to the pysam package listed in the requirements.txt file: pysam==0.8.4+gx1

The following error manifests: Collecting pysam==0.8.4+gx1 (from -r requirements.txt (line 69)) Could not find a version that satisfies the requirement pysam==0.8.4+gx1 (from -r requireme nts.txt (line 69)) (from versions: 0.4, 0.4.1, 0.7.6, 0.7.7, 0.7.8, 0.8.0, 0.8.1, 0.8.2, 0.8. 2.1, 0.8.3, 0.8.4, 0.9.0, 0.9.1,,, No matching distribution found for pysam==0.8.4+gx1 (from -r requirements.txt (line 69))

This package is installed, but not from the galaxy repo: [root@galaxy1 scripts]# pip install pysam Requirement already satisfied (use --upgrade to upgrade): pysam in /usr/lib64/python2.7/site-packages

Any ideas how to get past this issue? Thanks

galaxy • 264 views
ADD COMMENTlink modified 9 months ago • written 9 months ago by njoebott30
Please log in to add an answer.


Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 64 users visited in the last hour