Question: Problems with STACKs in
0
gravatar for Tianhua.He
2.6 years ago by
Tianhua.He0
Tianhua.He0 wrote:

Sorry for bothering you, but I have encountered some difficulties in using STACKS at galaxy (local instance). I am new to STACKS and Galaxy (and totally ignorant to programming), this problem has been troubling me for a few days. and wish anyone could advice to fix it. 

 

I installed STACKS from GUGGO tool shed to Galaxy, I think it is Stacks 1.18 version, but I was not able to install Package_bwa_0_6_2 into galaxy. Is STACKs bonded with version 0_6_2?  This is not a big issue as I could use other aligners to map the RAD reads to a reference genome, and import the SAM files to data library. 

When I deploy STACKS : Reference map, I was returned an error massage: 

error

An error occurred with this dataset:

Users/218496f/shed_tools/toolshed.genouest.org/repos/cmonjeau/stacks/4bbc09fa9b80/stacks/STACKS_refmap.py", line 16, in <module> from galaxy.datatypes.checkers import *

ImportError: no module named checkers.

 

I then managed to get a file called  “checkers.py” into galaxy/lib/galaxy/datatypes 

But that did not help, I still could not get it work, with an error message:

 

error

An error occurred with this dataset:

Users/218496f/shed_tools/toolshed.genouest.org/repos/cmonjeau/stacks/4bbc09fa9b80/stacks/STACKS_refmap.py", line 16, in <module> from galaxy.datatypes.checkers import *

File "/Users/218496f/galaxy/lib/gal

 

 I wish someone could advise on how to fix it. 

Thank you 

Tianhua

galaxy • 757 views
ADD COMMENTlink written 2.6 years ago by Tianhua.He0

This seems like a missing dependency ... best is to contact the guys behind this ToolShed.

ADD REPLYlink written 2.6 years ago by Bjoern Gruening5.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 120 users visited in the last hour