Question: how to set up ruby environment
0
gravatar for Brad Langhorst
4.4 years ago by
United States
Brad Langhorst100 wrote:

I need to set up a ruby environment for a tool.

I see 

https://wiki.galaxyproject.org/ToolDependenciesTagSets

has a setup_ruby_environment but I don't understand how to use it.

Does anyone know of an example tool that does this?

(ideally it would specify a ruby version and a gem set or run bundler to get all the gems available)

 

tool galaxy ruby • 930 views
ADD COMMENTlink modified 4.4 years ago by Bjoern Gruening5.1k • written 4.4 years ago by Brad Langhorst100
0
gravatar for Bjoern Gruening
4.4 years ago by
Bjoern Gruening5.1k
Germany
Bjoern Gruening5.1k wrote:

Hi Brad,

have a look at https://github.com/bgruening/galaxytools/blob/master/orphan_tool_dependencies/package_ruby2_bioruby_1_4/tool_dependencies.xml.

It's one of my test repositories for the ruby tag.

Cheers,

Bjoern

 

ADD COMMENTlink written 4.4 years ago by Bjoern Gruening5.1k

I'm wondering about how these packages are resolved.

Are you using bundler to resolve the packages?

Is there any support for Gemfile or .ruby_version in the tool directory?

Maybe you can point me at the setup_ruby_environment action - i couldn't find it in your repo.

Thanks!

Brad

 

 

ADD REPLYlink written 4.4 years ago by Brad Langhorst100

Hi Brad,

are you searching for https://github.com/bgruening/galaxytools/blob/master/orphan_tool_dependencies/package_ruby_2_0/tool_dependencies.xml ?

You can specify a path to a Gemfile yes and the version is given by the referenced package (package_ruby_2_0).

Cheers,

Bjoern

ADD REPLYlink written 4.4 years ago by Bjoern Gruening5.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 101 users visited in the last hour