Question: Database connection error
1
gravatar for bravobih
4.5 years ago by
bravobih • 30
European Union
bravobih • 30 wrote:

After fresh installation of Galaxy (on Linux Mint 16) as it is explained in https://wiki.galaxyproject.org/Admin/GetGalaxy

run.sh reports the following errors:

migrate.versioning.repository DEBUG 2014-05-27 11:11:58,601 Config: OrderedDict([('db_settings', OrderedDict([('__name__', 'db_settings'), ('repository_id', 'Galaxy'), ('version_table', 'migrate_version'), ('required_dbs', '[]')]))])
galaxy.model.migrate.check DEBUG 2014-05-27 11:11:58,603 psycopg2 egg successfully loaded for postgresql dialect
Traceback (most recent call last):
  File "/home/galaxy/galaxy-dist/lib/galaxy/webapps/galaxy/buildapp.py", line 39, in app_factory
    app = UniverseApplication( global_conf = global_conf, **kwargs )
  File "/home/galaxy/galaxy-dist/lib/galaxy/app.py", line 43, in __init__
    self._configure_models( check_migrate_databases=True, check_migrate_tools=True, config_file=config_file )
  File "/home/galaxy/galaxy-dist/lib/galaxy/config.py", line 601, in _configure_models
    create_or_verify_database( db_url, config_file, self.config.database_engine_options, app=self )
  File "/home/galaxy/galaxy-dist/lib/galaxy/model/migrate/check.py", line 66, in create_or_verify_database
    dataset_table = Table( "dataset", meta, autoload=True )
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/schema.py", line 318, in __new__
    table._init(name, metadata, *args, **kw)
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/schema.py", line 381, in _init
    self._autoload(metadata, autoload_with, include_columns)
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/schema.py", line 408, in _autoload
    self, include_columns, exclude_columns
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/engine/base.py", line 2423, in run_callable
    conn = self.contextual_connect()
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/engine/threadlocal.py", line 55, in contextual_connect
    connection = self._tl_connection_cls(self, self.pool.connect(), **kw)
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/pool.py", line 236, in connect
    return _ConnectionFairy(self).checkout()
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/pool.py", line 401, in __init__
    rec = self._connection_record = pool._do_get()
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/pool.py", line 746, in _do_get
    con = self._create_connection()
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/pool.py", line 189, in _create_connection
    return _ConnectionRecord(self)
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/pool.py", line 282, in __init__
    self.connection = self.__connect()
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/pool.py", line 344, in __connect
    connection = self.__pool._creator()
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/engine/strategies.py", line 80, in connect
    return dialect.connect(*cargs, **cparams)
  File "/home/galaxy/galaxy-dist/eggs/SQLAlchemy-0.7.9-py2.7-linux-x86_64-ucs4.egg/sqlalchemy/engine/default.py", line 281, in connect
    return self.dbapi.connect(*cargs, **cparams)
  File "/home/galaxy/galaxy-dist/eggs/psycopg2-2.5.1_9.2.4_static-py2.7-linux-x86_64-ucs4.egg/psycopg2/__init__.py", line 164, in connect
    conn = _connect(dsn, connection_factory=connection_factory, async=async)
OperationalError: (OperationalError) could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?

On the web site the error traceback is:

OperationalError: (OperationalError) no such table: galaxy_session u'INSERT INTO galaxy_session (create_time, update_time, user_id, remote_host, remote_addr, referer, current_history_id, session_key, is_valid, prev_session_id, disk_usage) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)' ('2014-05-27 07:59:50.498341', '2014-05-27 07:59:50.498346', None, '127.0.0.1', '127.0.0.1', None, None, 'e2e7db79c15d88f58503f6141a1aa3f4', 1, None, None):

What may be the problem?

 
software error galaxy • 1.6k views
ADD COMMENT • link • modified 4.5 years ago by Dannon Baker ♦ 3.7k • written 4.5 years ago by bravobih • 30
0
gravatar for Dannon Baker
4.5 years ago by
Dannon Baker ♦ 3.7k
United States
Dannon Baker ♦ 3.7k wrote:

This indicates your database connection info in universe_wsgi.ini is most likely incorrect.  The initial run script should automatically connect to your database and (along with many others) create that table.

Are you trying to connect to a local or remote database?  Can you share the connection string info you're trying to use (but do redact the password)?

ADD COMMENT • link written 4.5 years ago by Dannon Baker ♦ 3.7k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 166 users visited in the last hour