Question: Galaxy Cloudman - Nodes Can'T Make Their Own Qsub Calls?
0
gravatar for mailing list
6.2 years ago by
mailing list • 840
mailing list • 840 wrote:
Hi guys, I created a new Galaxy instance web launcher (https://biocloudcentral.herokuapp.com/launch) and then I ssh'd into the master node. I'm trying to run a Perl script that makes several qsub calls to other perl scripts. Now the catch is that one of those perl scripts makes its own qsub calls. And I'm getting this error when it tries to do that: Unable to run job: denied: host "ip-10-29-176-111.ec2.internal" is no submit host. Somehow this works fine on other clusters I've run this code on. Any idea what could be going on? Do I need to make all of the nodes "submit hosts"? Thanks a bunch! -Greg
galaxy • 1.9k views
ADD COMMENT • link • modified 6.2 years ago • written 6.2 years ago by mailing list • 840
0
gravatar for mailing list
6.2 years ago by
mailing list • 840
mailing list • 840 wrote:
As a follow up I found a command that should add the new nodes as submit hosts and I tried to run it but I got this error: $ qconf -as ip-10-28-164-178.ec2.internal denied: "ubuntu" must be manager for this operation What does it mean by manager? How would I run this command? I guess my preference is for Cloudman to do this automatically though so I'll be distributing this program to 3rd party users using the built-in cloudman sharing. I can't rightly ask users to be running qconf. Thanks again, Greg
ADD COMMENT • link written 6.2 years ago by mailing list • 840
You probably need to sudo to sgeadmin (cloudman guys correct me if you have this setup differently). I don't see any reason not to make worker nodes submit hosts by default in a future cloudman release. -- jt
ADD REPLY • link written 6.2 years ago by James Taylor ♦ 470
Thanks James. I'll give that a try. That would be excellent if you could make work nodes submit hosts by default in a future release. How would I get that on the plans? Submit a ticket somewhere? I guess in the meantime I could write a python script that runs qconf -sconfl to list all the hosts and for any that aren't listed when running qconf -ss, it would run qconf -as hostname on them. -Greg
ADD REPLY • link written 6.2 years ago by mailing list • 840
Ok, here's what I tried: $ sudo -u sgeadmin qconf -as ip-10-29-213-80.ec2.internal sudo: qconf: command not found So then I tried: $ which qconf /opt/sge/bin/lx24-amd64/qconf $ sudo -u sgeadmin /opt/sge/bin/lx24-amd64/qconf -as ip-10-29-213-80.ec2.internal critical error: Please set the environment variable SGE_ROOT. So then I tried: $ echo $SGE_ROOT /opt/sge $ sudo -u sgeadmin export SGE_ROOT=/opt/sge sudo: export: command not found Any ideas? I don't have the greatest understanding of the export command. Thanks again, Greg
ADD REPLY • link written 6.2 years ago by mailing list • 840
Spoke too soon! $ sudo -E -u sgeadmin /opt/sge/bin/lx24-amd64/qconf -as ip-10-29-213-80.ec2.internal worked fine. -E tells sudo to use the users environment. -Greg
ADD REPLY • link written 6.2 years ago by mailing list • 840
Hey all, Here's the one-liner I came up with for my users to run until this is changed in Galaxy: $ qconf -sconfl | xargs -l sudo -E -u sgeadmin /opt/sge/bin/lx24-amd64/qconf -as (in case anyone is interested) -Greg
ADD REPLY • link written 6.2 years ago by mailing list • 840
Added: worker nodes are now submit hosts as well: https://bitbucket.org/galaxy/cloudman/changeset/b4c66783b42fb559b35b68 9363b34826d00ced34 This will be generally available with the next release of CloudMan is made (however, there is no immediate plans for doing so as quite a bit of other details need to ironed out before the code is stable).
ADD REPLY • link written 6.2 years ago by Enis Afgan • 680
Thanks Enis. You guys are fast! Feel free to pass on my one-liner if anyone needs this before the next release. -Greg
ADD REPLY • link written 6.2 years ago by mailing list • 840
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 168 users visited in the last hour