Question: WARNING:galaxy.model:Datatype class not found for extension 'text'
0
gravatar for ana
7 days ago by
ana0
ana0 wrote:

Hi Galaxy Team,

I am developing a Galaxy based web server on Galaxy 18.05 release. I am adding chemoinformatics tools such as file-format converter etc. I am getting an error while executing jobs as given below: WARNING:galaxy.model:Datatype class not found for extension 'text'

As per some help online I checked that "datatypes_conf.xml" file has all the molecules formats but still this error is coming.

Also I tried converter for galaxy toolshed (CADDSuite), this tool is also not able to detect the sdf file format and other molecule file formats. Screen-shots for same are attached here.

Note: Same tools use to work in earlier versions easily but in this release they are not working.

Can you please help and what changes can be done to rectify this error.

Thank You

https://i.postimg.cc/MTKJnCfL/image.png

https://i.postimg.cc/ZR7tpwr5/image.png

galaxy • 24 views
ADD COMMENTlink modified 6 days ago by Jennifer Hillman Jackson25k • written 7 days ago by ana0
0
gravatar for Jennifer Hillman Jackson
6 days ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

CADDSuite hasn't been updated since 2012. Galaxy has had many changes since then. A 6+ year gap since the last update is a very long time. The wrappers probably require updates to be current/functional in the newer Galaxy releases.

Options:

  • Contact the authors of these tools through the ToolShed https://usegalaxy.org/toolshed (login > Repository actions > Contact author) or directly at their Github repositories (links are in the ToolShed, per tool, example: http://caddsuite.github.com >> https://github.com/CADDSuite/main/tree/master/packaging/galaxy) to report the problems, learn more about ongoing support status, and if there are plans to upgrade the wrappers to work with newer Galaxy releases.

  • Keep using an earlier version of Galaxy that you know works with the tools. Not all community tool authors will continue to update/support tools over time.

  • Consider using the more currently wrapped/supported tools from the Category > Computational chemistry available in the ToolShed. The minimum Galaxy version supported/known to work with tools is noted on repository landing pages for tools wrapped in the last few years (when the author submits this type of repository metadata).

Thanks! Jen, Galaxy team

ADD COMMENTlink written 6 days ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 152 users visited in the last hour