Question: Env build up: yarn installation error, unable to access git
0
gravatar for feliyon
10 days ago by
feliyon10
Peru/Lima
feliyon10 wrote:

Hello Community,

We have been trying to install Galaxy on VM with CentOS before installing in server, and unlike my previous experience with Ubuntu, we found some problems on apparently connectivity to https. When starting galaxy, the .env had problem to retrieve and install yarn packages, since it was unable to access the 'https://github.com/sorich87/bootstrap-tour.git/'. Problematic output follows.

sh run.sh
.....
You are using pip version 9.0.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
galaxy.dependencies.optional: no config file found
The Galaxy client has not yet been built and will be built now.
Installing node into /home/julloa/galaxy-master/.venv with nodeenv.
 * Install prebuilt node (9.11.1) ..... done.
 * Appending data to /home/julloa/galaxy-master/.venv/bin/activate
 * Appending data to /home/julloa/galaxy-master/.venv/bin/activate.fish
Installing yarn into /home/julloa/galaxy-master/.venv with npm.
/home/julloa/galaxy-master/.venv/bin/yarn -> /home/julloa/galaxy-master/.venv/lib/node_modules/yarn/bin/yarn.js
/home/julloa/galaxy-master/.venv/bin/yarnpkg -> /home/julloa/galaxy-master/.venv/lib/node_modules/yarn/bin/yarn.js
+ yarn@1.9.4
added 1 package in 1.397s
cd client && yarn install --network-timeout 120000 --check-files
yarn install v1.9.4
[1/4] Resolving packages...
[2/4] Fetching packages...
error Command failed.
Exit code: 128
Command: git
Arguments: ls-remote --tags --heads https://github.com/sorich87/bootstrap-tour.git
Directory: /home/julloa/galaxy-master/client
Output:
fatal: unable to access 'https://github.com/sorich87/bootstrap-tour.git/': Peer reports incompatible or unsupported protocol version.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
make: *** [node-deps] Error 1
ERROR: Galaxy client build failed. See ./client/README.md for more information, including how to get help.

Also: I tried installing the yarn directly in client and comes similar issue, also any suggestion to upgrade the pip? I did but to default lib, I couldn't in the .env

Thanks for the support!

vm git galaxy local • 65 views
ADD COMMENTlink modified 10 days ago by sargentl20 • written 10 days ago by feliyon10
2
gravatar for sargentl
10 days ago by
sargentl20
sargentl20 wrote:

per https://stackoverflow.com/questions/48938385/github-unable-to-access-ssl-connect-error:

"I was having the same problem on various CentOS 6 VM's and it turned out to be an issue with stale curl and nss libraries (thanks to this thread for pointing me in the right direction: cURL SSL connect error 35 with NSS error -5961).

The fix that worked for me is just:

yum update -y nss curl libcurl"

is this helpful?

  • EDIT this seems only somewhat related, but worth a check -- will dig in further

  • EDIT 2: this seems to corroborate the above in a more relevant scenario

ADD COMMENTlink modified 10 days ago • written 10 days ago by sargentl20
1

Indeed it work out, thank you for the suggestion. I was not aware of this NSS libraries update. By looking at it, git changed this February their SSL/TSL certifications, that is why before I didn't have that problem.

Thanks for the help!

ADD REPLYlink written 10 days ago by feliyon10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 106 users visited in the last hour