Question: Galaxy fails to submit job because of no active DRMAA session
0
gravatar for manuel.pasieka
22 months ago by
manuel.pasieka • 30 wrote:

Hello,

I am very new to galaxy, and I try to setup a local installation that is submitting jobs to a cluster running PBSPro 13.0.2. Running local jobs works fine, but all jobs on the cluster fail, and the run.sh console output tells mt

galaxy.jobs.runners.drmaa DEBUG 2017-01-23 17:23:01,277 (36)
submitting file /home/GMI/biocomp.pacbio/galaxy/galaxy/database/jobs_directory/000/36/galaxy_36.sh
galaxy.jobs.runners.drmaa ERROR 2017-01-23 17:23:01,278 (36)
drmaa.Session.runJob() failed unconditionally Traceback (most recent call last):
File "/home/GMI/biocomp.pacbio/galaxy/galaxy/lib/galaxy/jobs/runners/drmaa.py", line 178, in queue_job external_job_id = self.ds.run_job(**jt)
File "/home/GMI/biocomp.pacbio/galaxy/galaxy/.venv/local/lib/python2.7/site-packages/pulsar/managers/util/drmaa/__init__.py" line 67, in run_job
return DrmaaSession.session.runJob(template)
File "/home/GMI/biocomp.pacbio/galaxy/galaxy/.venv/local/lib/python2.7/site-packages/drmaa/session.py", line 314, in runJob c(drmaa_run_job, jid, sizeof(jid), jobTemplate)   File "/home/GMI/biocomp.pacbio/galaxy/galaxy/.venv/local/lib/python2.7/site-packages/drmaa/helpers.py", line 299, in c
return f(*(args + (error_buffer, sizeof(error_buffer))))   File "/home/GMI/biocomp.pacbio/galaxy/galaxy/.venv/local/lib/python2.7/site-packages/drmaa/errors.py", line 151, in error_check raise _ERRORS[code - 1](error_string)
NoActiveSessionException: code 5: No active DRMAA session. galaxy.jobs.runners.drmaa ERROR
 2017-01-23 17:23:01,290 (36) All attempts to submit job failed

The config/job_conf.xml looks as follows

<?xml version="1.0"?>
<job_conf>
    <plugins>
            <plugin id="pbs" type="runner" load="galaxy.jobs.runners.drmaa:DRMAAJobRunner"/>
            <plugin id="local" type="runner" load="galaxy.jobs.runners.local:LocalJobRunner" workers="4"/>
    </plugins>

    <handlers>
            <handler id="main"/>
    </handlers>

    <destinations default="mendel">
        <destination id="local" runner="local"/>
        <destination id="mendel" runner="pbs">
            <param id="Resource_List">walltime=72:00:00,nodes=1:ppn=8</param>
            <param id="-q">workq</param>
            <env file="~/env_setup.sh" />
        </destination>
    </destinations>

<tools>
    <tool id="upload1" destination="local"/>
</tools>
</job_conf>

Do you have any suggetions? If you kneed any further information or config file, please ask.

thx, Manuel

galaxy drmaa • 723 views
ADD COMMENT • link • modified 22 months ago • written 22 months ago by manuel.pasieka • 30

Investigating the problem I found that the error "code 5: No active DRMAA session." is comming from the drmaa c library function runjob, producing the error code DRMAA_ERRNO_NO_ACTIVE_SESSION. This error indicates that drma_init was not run, see drmaa_init Could this be due to my particular setup? mentioned here

ADD REPLY • link written 22 months ago by manuel.pasieka • 30
0
gravatar for manuel.pasieka
22 months ago by
manuel.pasieka • 30 wrote:

The problem was caused because of a missing local DRM installation. See this followup post

ADD COMMENT • link written 22 months ago by manuel.pasieka • 30
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 169 users visited in the last hour