Question: Help with using the multiBam Summary tool - error message
0
gravatar for alim
15 months ago by
alim10
United Kingdom
alim10 wrote:

Hello,

I have just aligned some reads using Bowtie2 and am wanting to look at correlation between my replicates using the plotCorrelation tool. However, this requires a matrix file to first be generated with the multiBamSummary tool. I tried running the latter to generate the matrix but this error message came up:

Fatal error: Exit code 1 () Traceback (most recent call last): File "/galaxy-repl/main/jobdir/014/048/14048548/conda-env/bin/multiBamSummary", line 7, in <module> main() File "/galaxy-repl/main/jobdir/014/048/14048548/conda-env/lib/python2.7/site-packages/deeptools/multiBamSummary.py", line 224, in main num_reads_per_bin = c.run(allArgs=args) File "/galaxy-repl/main/jobdir/014/048/14048548/conda-env/lib/python2.7/site-packages/deeptools/countReadsPerBin.py", line 263, in run raise ValueError("numberOfSamples has to be bigger than {} ".format(min_num_of_samples)) ValueError: numberOfSamples has to be bigger than 99567

Could anyone help this ?

Cheers, Alfred

rna-seq software error bam • 495 views
ADD COMMENTlink modified 15 months ago • written 15 months ago by alim10

Which reference genome did you use?

ADD REPLYlink written 15 months ago by Devon Ryan1.9k
1
gravatar for Devon Ryan
15 months ago by
Devon Ryan1.9k
Germany
Devon Ryan1.9k wrote:

More generally, try setting the "Bin Size in bp" to a smaller value. It needs to be larger than the average chromosome/contig length, which doesn't always happen by default if you have a lot of really small contigs.

ADD COMMENTlink written 15 months ago by Devon Ryan1.9k
0
gravatar for alim
15 months ago by
alim10
United Kingdom
alim10 wrote:

Hi Devon,

Many thanks for getting back to me. What sort of range of bin size would you suggest please and how can I estimate that? My reads are all 50-bp fragments, aligned to mouse mm10 genome.

ADD COMMENTlink written 15 months ago by alim10
1

For mm10 you shouldn't have to change anything and you shouldn't be getting that error message. Please submit a big report within Galaxy and, in the part of the report where you can type stuff in, put a link to this post and ask the site administrator to contact me. For reference, the 99567 number is the number of chromosomes/contigs in the BAM files, so either you're not using mm10 but rather some other assembly (e.g., a different strain from the Mouse Genomes Project) or something went wrong when comparing the chromosome names.

ADD REPLYlink written 15 months ago by Devon Ryan1.9k

Agree that the problem is likely a genome mismatch issue from the given info. Compare each input - data based on the same exact reference genome must be used for all steps. https://wiki.galaxyproject.org/Support#Reference_genomes

If you cannot find the issue but can replicate this at http://usegalaxy.org, this is how to send in the bug report: https://wiki.galaxyproject.org/Support#Reporting_tool_errors

Leave all inputs/outputs undeleted and include a link to this biostars post.

Thanks, Jen, Galaxy team

ADD REPLYlink written 15 months ago by Jennifer Hillman Jackson23k

Thanks so much Devon and Jen - I will recheck my data and see if it was using the correct reference genome.

Cheers, Alfred

ADD REPLYlink written 15 months ago by alim10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 118 users visited in the last hour