Question: Installed tools not appearing in list of tools
0
gravatar for ablanchetcohen
22 months ago by
ablanchetcohen10 wrote:

Hi,

This is a new installation of Galaxy. I'm able to install tools, but they never appear in the list of installed tools.

These are what I believe to be the essential configuration files in galaxy.ini tool_sheds_config_file = config/tool_sheds_conf.xml tool_config_file = config/tool_conf.xml,config/shed_tool_conf.xml

The tools do appear in the list of installed tools in the administration panel. I have restarted Galaxy several times.

tool_conf.xml never appears to get updated.

The installed tools do appear in the tools dependency directory specified in galaxy.ini. tool_dependency_dir = /stockage/galaxy/dependency_dir

Thank you for your help,

Alexis

ADD COMMENTlink modified 22 months ago by Aris Adam10 • written 22 months ago by ablanchetcohen10

is the tool listed in config/shed_tool_conf.xml ?

try removing the file 'integrated_tool_panel.xml' and then restart......though this bug has been fixed several releases ago

Hans-Rudolf

ADD REPLYlink written 22 months ago by Hotz, Hans-Rudolf1.8k

No, the installed tool, hisat2, does not appear in shed_tool_conf.xml.

[galaxy@gen01 config]$ grep hisat shed_tool_conf.xml [galaxy@gen01 config]$

I don't have a file called integrated_tool_panel.xml.

[galaxy@gen01 config]$ pwd /home/galaxy/galaxy/config [galaxy@gen01 config]$ ls ntegrated_tool_panel.xml ls: cannot access ntegrated_tool_panel.xml: No such file or directory [galaxy@gen01 config]$

The file shed_tool_conf.xml does contain an entry for bwa, that I tried to install previously, and then uninstalled. bwa does not appear in the list of available tools either though.

Thank you for your help.

ADD REPLYlink modified 22 months ago • written 22 months ago by ablanchetcohen10

It's probably in /home/galaxy/galaxy (at least that'd be the equivalent of where mine ended up).

ADD REPLYlink written 22 months ago by Devon Ryan1.9k

I've tried restarting Galaxy yet again. I just don't see any changes.

hisat appears in the list of installed tools in the Admin panel, but a search of hisat in "Search tools" returns nothing, and there is no entry for hisat in tool_conf.xml.

Is tool_conf.xml supposed to get updated?

ADD REPLYlink written 22 months ago by ablanchetcohen10

Am I supposed to uncomment this line in galaxy.ini, and then restart Galaxy?

# File that contains the XML section and tool tags from all tool panel config

# files integrated into a single file that defines the tool panel layout. This

# file can be changed by the Galaxy administrator to alter the layout of the

# tool panel. If not present, Galaxy will create it.

#integrated_tool_panel_config = integrated_tool_panel.xml

Sorry, this should not be a reply, but I clicked on the wrong button, and there is no delete option.

ADD REPLYlink modified 22 months ago • written 22 months ago by ablanchetcohen10

I did try uncommenting this line, and restarting Galaxy. No integrated_tool_panel.xml file appeared.

Still, none of the installed tools appear in the list of tools. :(

ADD REPLYlink written 22 months ago by ablanchetcohen10
1

Has this issue been resolved? Just checking in. You can create a reply yourself that includes the solution and moderate this issue as accepted/resolved. Thanks, Jen, Galaxy team

ADD REPLYlink written 22 months ago by Jennifer Hillman Jackson25k

No, I wish it had. :( I'll try do some more troubleshooting, and report the results here, but I'm still looking for an answer if anyone has one.

ADD REPLYlink modified 22 months ago • written 22 months ago by ablanchetcohen10

Have you been able to solve this? I'm currently experiencing similar issues.

ADD REPLYlink written 7 months ago by Coryzaa10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 146 users visited in the last hour