Question: Tool Installation from Tool Shed
1
gravatar for hortowe
20 months ago by
hortowe10
hortowe10 wrote:

Hi all,

I recently downloaded and installed a local version of Galaxy and am following some basic tutorials. I'm currently attempting to install a tool from the toolshed (https://wiki.galaxyproject.org/Admin/Tools/AddToolFromToolShedTutorial).

I checked the tool_sheds_conf.xml file and the main tool shed is there.

I also created a tool dependencies directory: /config/tool_dependencies and edited my galaxy.ini file: (line 173) tool_dependency_dir = config/tool_dependencies

I follow the rest of the instructions to search for and install the tool (I'm attempting to install PEAR, but I receive the same error regardless of the tool I attempt to install)

On my galaxy interface, in the "monitor installing tool shed repositories," the status goes from "new" to "error" and in my terminal output, I get:

galaxy.tools.toolbox.base DEBUG 2016-03-25 11:19:04,590 Appending to tool panel section: Preprocess tool_shed.util.hg_util DEBUG 2016-03-25 11:19:04,779 Error cloning repository: can't clear options before OpenSSL 0.9.8m

I appreciate any help/suggestions on how to go about figuring this out!

galaxy • 701 views
ADD COMMENTlink modified 20 months ago by Martin Čech ♦♦ 4.2k • written 20 months ago by hortowe10
1
gravatar for Martin Čech
20 months ago by
Martin Čech ♦♦ 4.2k
United States
Martin Čech ♦♦ 4.2k wrote:

You might be experiencing this Python bug:

http://bugs.python.org/issue12440

In which case I would start with confirming your Python version and then following the steps from the link above.

related link: http://stackoverflow.com/questions/31343474/error-in-ssl-wrapper-while-cloning-with-mercurial

ADD COMMENTlink modified 20 months ago • written 20 months ago by Martin Čech ♦♦ 4.2k

Thanks for the reply Martin. I don't think that python bug applies to me, my python version is Python 2.7.10 and I'm running OS X Yosemite 10.10.5. I followed the instructions in the final answer on that stack overflow link and have this: ~$ which python /usr/local/bin/python

~$ ls -la /usr/local/bin/python /usr/local/bin/python@ -> /System/Library/Frameworks/Python.framework/Versions/2.7/bin/python

But still received the same error. I also edited my .bash_profile to contain: export DYLD_LIBRARY_PATH=/usr/bin/openssl:$DYLD_LIBRARY_PATH

As well as checked shared libraries with: ~$ otool -L /usr/bin/openssl /usr/bin/openssl: /usr/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8) /usr/lib/libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8) /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1213.0.0)

Still getting the same error. Should I be setting something differently with the DYLD_LIBRARY_PATH?

ADD REPLYlink written 20 months ago by hortowe10

I am afraid I cannot help you more here as I am far from being a sysadmin and this feels like a sysadmin problem. I have a very similar system to yours and never seen this problem. Maybe somebody else will respond.

ADD REPLYlink written 20 months ago by Martin Čech ♦♦ 4.2k

I ended up just switching to a new computer...not much of a solution but at least I don't have to worry about it anymore! Thanks for your help.

ADD REPLYlink written 20 months ago by hortowe10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 92 users visited in the last hour