Question: Install-tools via yaml file error
0
gravatar for Philipp.rathert
2.6 years ago by
Germany
Philipp.rathert30 wrote:

dear all, I want to install a bunch of tools using the install-tools function. In my yaml file tool.yml i have specified the url if my docker instance wit the ip adress i use in the web browser and the api_key is admin

When i run install-tools i get this and nothing happens.

Anybody has an idea whats wrong?

root@galaxy:/galaxy-central# install-tools tool.yml * Starting PostgreSQL 9.3 database server [ OK ] starting Galaxy Activating virtualenv at .venv Ignoring indexes: https://pypi.python.org/simple /galaxy-central/.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning. SNIMissingWarning /galaxy-central/.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning. InsecurePlatformWarning Requirement already up-to-date: pip==8.0.2+gx2 in ./.venv/lib/python2.7/site-packages Requirement already satisfied (use --upgrade to upgrade): bx-python==0.7.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 2)) Requirement already satisfied (use --upgrade to upgrade): MarkupSafe==0.23 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 3)) Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.11 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 4)) Requirement already satisfied (use --upgrade to upgrade): SQLAlchemy==1.0.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 5)) Requirement already satisfied (use --upgrade to upgrade): mercurial==3.4.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 7)) Requirement already satisfied (use --upgrade to upgrade): numpy==1.9.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 8)) Requirement already satisfied (use --upgrade to upgrade): pycrypto==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 9)) Requirement already satisfied (use --upgrade to upgrade): Paste==2.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 16)) Requirement already satisfied (use --upgrade to upgrade): PasteDeploy==1.5.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 17)) Requirement already satisfied (use --upgrade to upgrade): docutils==0.12 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 18)) Requirement already satisfied (use --upgrade to upgrade): wchartype==0.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 19)) Requirement already satisfied (use --upgrade to upgrade): repoze.lru==0.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 20)) Requirement already satisfied (use --upgrade to upgrade): Routes==2.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 21)) Requirement already satisfied (use --upgrade to upgrade): WebOb==1.4.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 22)) Requirement already satisfied (use --upgrade to upgrade): WebHelpers==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 23)) Requirement already satisfied (use --upgrade to upgrade): Mako==1.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 24)) Requirement already satisfied (use --upgrade to upgrade): pytz==2015.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 25)) Requirement already satisfied (use --upgrade to upgrade): Babel==2.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 26)) Requirement already satisfied (use --upgrade to upgrade): Beaker==1.7.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 27)) Requirement already satisfied (use --upgrade to upgrade): Cheetah==2.4.4 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 30)) Requirement already satisfied (use --upgrade to upgrade): Markdown==2.6.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 31)) Requirement already satisfied (use --upgrade to upgrade): bioblend==0.6.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 34)) Requirement already satisfied (use --upgrade to upgrade): boto==2.38.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 35)) Requirement already satisfied (use --upgrade to upgrade): requests==2.8.1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 36)) Requirement already satisfied (use --upgrade to upgrade): requests-toolbelt==0.4.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 37)) Requirement already satisfied (use --upgrade to upgrade): kombu==3.0.30 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 40)) Requirement already satisfied (use --upgrade to upgrade): amqp==1.4.8 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 41)) Requirement already satisfied (use --upgrade to upgrade): anyjson==0.3.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 42)) Requirement already satisfied (use --upgrade to upgrade): sqlalchemy-migrate==0.10.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 45)) Requirement already satisfied (use --upgrade to upgrade): decorator==4.0.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 46)) Requirement already satisfied (use --upgrade to upgrade): Tempita==0.5.3dev in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 47)) Requirement already satisfied (use --upgrade to upgrade): sqlparse==0.1.16 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 48)) Requirement already satisfied (use --upgrade to upgrade): pbr==1.8.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 49)) Requirement already satisfied (use --upgrade to upgrade): six==1.9.0 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 51)) Requirement already satisfied (use --upgrade to upgrade): Parsley==1.3 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 52)) Requirement already satisfied (use --upgrade to upgrade): nose==1.3.7 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 53)) Requirement already satisfied (use --upgrade to upgrade): SVGFig==1.1.6 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 54)) Requirement already satisfied (use --upgrade to upgrade): Fabric==1.10.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 57)) Requirement already satisfied (use --upgrade to upgrade): paramiko==1.15.2 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 58)) Requirement already satisfied (use --upgrade to upgrade): ecdsa==0.13 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 59)) Requirement already satisfied (use --upgrade to upgrade): Whoosh==2.4.1+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 66)) Requirement already satisfied (use --upgrade to upgrade): pysam==0.8.4+gx1 in ./.venv/lib/python2.7/site-packages (from -r requirements.txt (line 69)) You are using pip version 8.0.2+gx2, however version 8.1.0 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Requirement already satisfied (use --upgrade to upgrade): psycopg2==2.6.1 in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 1)) Requirement already satisfied (use --upgrade to upgrade): drmaa in ./.venv/lib/python2.7/site-packages (from -r /dev/stdin (line 2)) You are using pip version 8.0.2+gx2, however version 8.1.0 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Activating virtualenv at .venv Daemon is already running (PID: 323 from PID file galaxy_install.pid) Galaxy is running.

PLAY *************************

TASK [galaxy_tools : include] **************** skipping: [localhost]

TASK [galaxy_tools : include] **************** included: /home/galaxy/ansible/galaxy-tools-playbook/roles/galaxy_tools/tasks/tools.yml for localhost

TASK [galaxy_tools : Create/invoke script virtualenv] ******** fatal: [localhost]: UNREACHABLE! => {"changed": false, "msg": "All items completed", "results": [{"item": "pyyaml", "msg": "Authentication or permission failure. In some cases, you may have been able to authenticate and did not have permissions on the remote directory. Consider changing the remote temp path in ansible.cfg to a path rooted in \"/tmp\". Failed command was: ( umask 22 && mkdir -p \"echo $HOME/.ansible/tmp/ansible-tmp-1457708936.13-72771790334072\" && echo \"echo $HOME/.ansible/tmp/ansible-tmp-1457708936.13-72771790334072\" ), exited with result 1", "unreachable": true}, {"item": "bioblend", "msg": "Authentication or permission failure. In some cases, you may have been able to authenticate and did not have permissions on the remote directory. Consider changing the remote temp path in ansible.cfg to a path rooted in \"/tmp\". Failed command was: ( umask 22 && mkdir -p \"echo $HOME/.ansible/tmp/ansible-tmp-1457708936.15-89736978480357\" && echo \"echo $HOME/.ansible/tmp/ansible-tmp-1457708936.15-89736978480357\" ), exited with result 1", "unreachable": true}]} to retry, use: --limit @tools.retry

PLAY RECAP *********************** localhost : ok=1 changed=0 unreachable=1 failed=0

yaml • 951 views
ADD COMMENTlink written 2.6 years ago by Philipp.rathert30
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 129 users visited in the last hour