Question: Transferring histories between galaxy instances using URLs
0
gravatar for Guy Reeves
2.7 years ago by
Guy Reeves1.0k
Germany
Guy Reeves1.0k wrote:

HI

I have been trying to use URLs to export histories from one galaxy instance to another.
I have described what I did when it worked in the following post

A: Transfer from one Galaxy server to another?

The very first time I tried the history transfer it worked but since then I have been unable to get it to work agin.

If I paste the export URL into a browser the history downloads as a file- indicating to me that the export part is fine But when I use the same URL in the "Import from File" command no new histories appear on any view. I can see from the admin> mange jobs panel that the import_job is actually completed almost instantly.

Any ideas about what is going wrong?

The history I am trying transfer as a test is small <1Mb.Both the galaxy instances are on the same network but different servers. Thanks Guy

import galaxy url export • 926 views
ADD COMMENTlink written 2.7 years ago by Guy Reeves1.0k

Hi Guy, I am doing some testing to see if there is a difference in protocol between methods, a possible bug, or similar. But have a few questions that will help us narrow down what is going on:

  1. Was the "from" history made accessible by URL through the history Share function? This is required additional step and noted in the blue message returned when the Export history to File function is used.

  2. How much time passed between creating the exported history URL and when you attempted to import through the "Import from File" function? These are cued jobs and take time to execute and complete. I also think that these are not retained on a server indefinitely, so the older URL may point to a non-existent file if some time has passed, but will double check on the exact time window (it may be configurable).

Thanks! Jen

ADD REPLYlink modified 2.7 years ago • written 2.7 years ago by Jennifer Hillman Jackson25k

HI Jen Thanks for the reply. Here is the answer 1 yes the history is made available to share 2 as soon as I see that the export command is complete (within 10 mins).

Does the fact that I can paste the same URL into a web-browser and the history downloads to my hard drive indicate that the export and share settings are OK? Thanks Guy

ADD REPLYlink written 2.7 years ago by Guy Reeves1.0k

I did also try stoping and restarting the instance and it did not help.

ADD REPLYlink written 2.7 years ago by Guy Reeves1.0k

Hi Guy, I was also unable to transfer by URL with import/export with one set of servers today, but Carl was able to do this between two locals. Have your local servers been updated to the most current Galaxy version? I'll also share this again with the dev team for more feedback.

ADD REPLYlink written 2.7 years ago by Jennifer Hillman Jackson25k

I am not sure about the second. I do know from prior usage that downloading becomes the default export option after one round of using this function. Not sure exactly why or if there is a way to backtrack. I checked with the team and exports are not purged quickly, but perhaps this changes once already downloaded. Let's see what other feedback we get. I pinged Carl again for assistance here, he is the expert in this area.

ADD REPLYlink written 2.7 years ago by Jennifer Hillman Jackson25k

I am updating to the latest versions I had 15.07 and 15.01

ADD REPLYlink written 2.7 years ago by Guy Reeves1.0k

Did that help?

If not, we can diagnose more.

ADD REPLYlink written 2.7 years ago by carlfeberhard390

I have a conventional instance version 16:01 and a docker instance version 15:07 (I am still in the process of trying to update the docker instance). I am trying to move histories from the 15:07 instance to the 16:01 they are both on the same network. The histories are very small. like I said it worked the fist time I did it. I do publish the history during the export step As I mentioned above if I past the URLs into browsers I get the .dat file downloaded.
I have tried moving histories in both directions 16:01 > 15:07 and 16:01 < 15:07 neither works for me.

I do not know if it is relevant by when I go to the view all histories I can see that on the far right 'Loading histories...' keeps cycling and never stops.

ADD REPLYlink written 2.7 years ago by Guy Reeves1.0k

That last part isn't part of it, no. It's a separate bug.

Ok - 16.01 is what I've tested on here and should be alright. What do the logs say for that instance around the time you tried importing to it?

ADD REPLYlink written 2.7 years ago by carlfeberhard390
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 106 users visited in the last hour