Question: Galaxy crashing, running out of memory (database upload?)
0
gravatar for danielfortin86
2.8 years ago by
United States
danielfortin86 • 110 wrote:

Hi,

 

For some reason my Galaxy process gets killed because it runs out of memory after a few seconds (running with 64Gb on a VM). I'm using postgres and notice that while Galaxy is running that it uses 100% CPU, while the Galaxy processes' memory quickly rises until the process gets killed. Using the Galaxy reports framework it looks like there is a running job related to uploading. Could this job be what's causing this memory failure? If so, how do I kill this job? Can I manually remove this from the postgres database? How would I do this? Any suggestions would be greatly appreciated! Please see below for the error message

 

Thanks!!

 

Out of memory: Kill process 3616 (python) score 986 or sacrifice child

Killed process 3616, UID 551, (python) total-vm:68426688kB, anon-rss:65019188kB, file-rss:4kB

crash postgres • 801 views
ADD COMMENT • link • modified 2.8 years ago • written 2.8 years ago by danielfortin86 • 110
0
gravatar for danielfortin86
2.8 years ago by
United States
danielfortin86 • 110 wrote:

In case anyone runs into this issue, apparently the last job in the postgres database was causing these issues. This job was related to adding files to a shared data library. Loosely following the instructions in Section 8.2 below solved the issue:

http://ihpe.univ-perp.fr/methods/methods/Galaxy_production_mode_installation_walkthrough.html

After deletion of all database entries related to the last job, galaxy again runs without issues. 

 

 

 

ADD COMMENT • link written 2.8 years ago by danielfortin86 • 110
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 173 users visited in the last hour