Question: Problem with Visualization / Charts on local Galaxy installation
0
gravatar for danielfortin86
2.2 years ago by
United States
danielfortin86100 wrote:

Hi,

I'm having a problem with using charts on my local galaxy installation. When I click on the visualization icon and select charts, I get a blank screen. See below for relevant lines from the "paster.log" file:

galaxy.webapps.galaxy.controllers.visualization ERROR 2015-11-03 09:31:18,759 error rendering visualization (charts): (SyntaxError) invalid syntax (<unknown>, line 7) (u"h.js( 'libs/jquery/jquery',\n                'libs/") in file 'config/plugins/visualizations/charts/templates/charts.mako' at line: 14 char: 9
Traceback (most recent call last):
  File "/opt/galaxy-dist/lib/galaxy/webapps/galaxy/controllers/visualization.py", line 732, in render
    return plugin.render( trans=trans, embedded=embedded, **kwargs )
  File "/opt/galaxy-dist/lib/galaxy/visualization/plugins/plugin.py", line 139, in render
    return self._render( render_vars, trans=trans, embedded=embedded )
  File "/opt/galaxy-dist/lib/galaxy/visualization/plugins/plugin.py", line 238, in _render
    return trans.fill_template( template_filename, template_lookup=self.template_lookup, **render_vars )
  File "/opt/galaxy-dist/lib/galaxy/web/framework/webapp.py", line 810, in fill_template
    return self.fill_template_mako( filename, **kwargs )
  File "/opt/galaxy-dist/lib/galaxy/web/framework/webapp.py", line 818, in fill_template_mako
    template = template_lookup.get_template( filename )
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/lookup.py", line 218, in get_template
    return self._load(srcfile, uri)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/lookup.py", line 283, in _load
    **self.template_args)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/template.py", line 218, in __init__
    module = self._compile_from_file(path, filename)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/template.py", line 244, in _compile_from_file
    path)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/template.py", line 507, in _compile_module_file
    node = lexer.parse()
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/lexer.py", line 209, in parse
    if self.match_expression():
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/lexer.py", line 369, in match_expression
    lineno=line, pos=pos)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/lexer.py", line 125, in append_node
    node = nodecls(*args, **kwargs)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/parsetree.py", line 172, in __init__
    self.code = ast.PythonCode(text, **self.exception_kwargs)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/ast.py", line 34, in __init__
    expr = pyparser.parse(code.lstrip(), "exec", **exception_kwargs)
  File "/opt/galaxy-dist/eggs/Mako-0.4.1-py2.6.egg/mako/pyparser.py", line 60, in parse
    ), **exception_kwargs)
SyntaxException: (SyntaxError) invalid syntax (<unknown>, line 7) (u"h.js( 'libs/jquery/jquery',\n                'libs/") in file 'config/plugins/visualizations/charts/templates/charts.mako' at line: 14 char: 9

 

visualization charts • 2.5k views
ADD COMMENTlink written 2.2 years ago by danielfortin86100

Thank you for reporting this. Can you specify the revision and branch you are using?

ADD REPLYlink written 2.2 years ago by aysam.guerler70

I'm currently using 15.07 via mercurial

ADD REPLYlink written 2.2 years ago by danielfortin86100

I have tried this in 15.10 now with the same result 

ADD REPLYlink written 24 months ago by danielfortin86100
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 98 users visited in the last hour