Question: Cuffdiff Error on local Galaxy
0
gravatar for gkuffel22
3.5 years ago by
gkuffel22170
United States
gkuffel22170 wrote:

Hi,

I am attempting to use the tool Cuffdiff on a local instance of Galaxy. I am getting the following error: Error in library("cummerbund"): there is no package called 'cummeRbund'

Does this tool have a dependency that needs to be installed or is it something else. Thanks everyone.

 

cuffdiff • 1.1k views
ADD COMMENTlink modified 3.5 years ago by Jennifer Hillman Jackson25k • written 3.5 years ago by gkuffel22170
0
gravatar for Jennifer Hillman Jackson
3.5 years ago by
United States
Jennifer Hillman Jackson25k wrote:

Hello,

There are no known issues with this repository. When installing through the Admin panel from the Tool Shed, did you have the checkboxs for installing repository and tool dependencies checked? If not, or you are not sure, try uninstalling (completely), then reinstalling using this method as a first past solution.

When installing tools - and I realize this seems obvious - be sure to double check that this was successful by reviewing installed repos. Issues can be easy to miss, if not specifically reviewed. If there was a problem or an update is available, it will be noted. Now, that will not give you information about uninstalled dependencies (necessarily, in particular if the 'installing managed dependencies' option was not used).

Please let us know how it goes, Jen, Galaxy team

ADD COMMENTlink modified 3.5 years ago • written 3.5 years ago by Jennifer Hillman Jackson25k

Hi Jen,

Thank you for your response. I have recently been granted admin privileges to our local Galaxy instance and am doing my best to get on top of everything. I was not the person that originally installed these tools. I now realize that the reason Cuffdiff is not working is because it has a dependency on package cummerbund 2.8.2 and for some reason there was an error installing this package during the original installation and now that I have un-installed everything as you suggested and re-ininstalled the server is still having a hard time installing the tool dependencies of the package cummerbund itself, specifically I get an erro for R version 3.1.2 and cummerbund 2.8.2 displays "Installing" but nothing seems to happen.

ADD REPLYlink written 3.5 years ago by gkuffel22170
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 140 users visited in the last hour