Question: Jobs stuck waiting after local instance restart
0
gravatar for letawjohn
2.8 years ago by
letawjohn0
United States
letawjohn0 wrote:

I'm having trouble correcting this one...

I made some changes to a specific tool, and then proceeded to restart our local Galaxy instance with ./run.sh --daemon restart.  Upon restart I tried to rerun the aforementioned tool, but it has decided to become stuck in the grey waiting to run state.  Other tools that were not modified also behave this way.  Upon looking at the bottom of the handler log, I am finding a message that I should not be running jobs at root:

galaxy.jobs.runners ERROR 2015-03-05 09:16:27,875 (1510) Unhandled exception calling queue_job

Traceback (most recent call last):

  File "/hdd_pool/hdd_zfs/galaxy-dist/lib/galaxy/jobs/runners/__init__.py", line 96, in run_next

    method(arg)

  File "/hdd_pool/hdd_zfs/galaxy-dist/lib/galaxy/jobs/runners/drmaa.py", line 199, in queue_job

    external_job_id = self.ds.runJob(jt)

  File "/hdd_pool/hdd_zfs/galaxy-dist/eggs/drmaa-0.7.6-py2.7.egg/drmaa/session.py", line 314, in runJob

    c(drmaa_run_job, jid, sizeof(jid), jobTemplate)

  File "/hdd_pool/hdd_zfs/galaxy-dist/eggs/drmaa-0.7.6-py2.7.egg/drmaa/helpers.py", line 299, in c

    return f(*(args + (error_buffer, sizeof(error_buffer))))

  File "/hdd_pool/hdd_zfs/galaxy-dist/eggs/drmaa-0.7.6-py2.7.egg/drmaa/errors.py", line 151, in error_check

    raise _ERRORS[code - 1](error_string)

InvalidAttributeValueException: code 14: ERROR: Submitting jobs as user/group 0 (root) is not allowed for security reasons.

As this was not happening pre-restart, I am having trouble figuring out what has gone wrong, does anyone have any insights for me?

Thanks!

realuser root jobs local drmaa • 722 views
ADD COMMENTlink modified 2.8 years ago by Jennifer Hillman Jackson23k • written 2.8 years ago by letawjohn0
2
gravatar for Jennifer Hillman Jackson
2.8 years ago by
United States
Jennifer Hillman Jackson23k wrote:

Hello,

Perhaps start by reviewing the job running set up? Maybe something was changed other than the single tool? This wiki has details:
http://wiki.galaxyproject.org/Admin/Config/Performance/Cluster

Make sure you are running the latest distribution as well, this ensures that troubleshooting is working off of the same base Galaxy version.

Best, Jen, Galaxy team

ADD COMMENTlink written 2.8 years ago by Jennifer Hillman Jackson23k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 107 users visited in the last hour