Question: Grabbing environment variables from previously added tools for new tool installation
0
gravatar for marcoalbuquerque.sfu
3.6 years ago by
Canada
marcoalbuquerque.sfu50 wrote:

Hello Galaxy,

I am currently working on automatic installation for DELLY.

DELLY has 3 major dependencies: boost, bamtools and seqtk. The way DELLY's current Makefile works is by passing in the directories of where these three major tools were built. The following is a sample command of how DELLY is built:

make all BOOST_ROOT=$BOOST_ROOT_DIR BAMTOOLS_ROOT=$BAMTOOLS_ROOT SEQTK_ROOT=$SEQTK_ROOT


The current issue is obtaining the BOOST_ROOT_DIR, BAMTOOLS_ROOT, and SEQTK_ROOT environment variables in the tool_dependency file. All three of these environment variables have been declared in each tools individual tool dependency file.

Please let me know if this is possible, and if so, how to do this!

Thanks Galaxy

 

 

 

ADD COMMENTlink modified 3.6 years ago by Bjoern Gruening5.1k • written 3.6 years ago by marcoalbuquerque.sfu50
1
gravatar for Bjoern Gruening
3.6 years ago by
Bjoern Gruening5.1k
Germany
Bjoern Gruening5.1k wrote:

Hi,

if you look at this boost definition file you will see a $BOOST_ROOT_DIR as you mentioned.

https://github.com/galaxyproject/tools-iuc/blob/master/packages/package_boost_1_55/tool_dependencies.xml

If you depend on this repository, you only need to add a "set_environment_for_install" action tag and can access $BOOST_ROOT_DIR.

<action type="set_environment_for_install">
    <repository name="package_boost_x_y" owner="iuc">
        <package name="boost" version="x_y" />
    </repository>
</action>

Cheers,

Bjoern

ADD COMMENTlink written 3.6 years ago by Bjoern Gruening5.1k

This worked!

I will add, that for some odd reason if the set_environment_for_install tag was before the download_by_url tag the working directory was changed and future shell commands were not executed properly. Im not sure if this is an error or if there is some meaning behind this madness, but I'd imagine that the order of set_environment_for_install and download_by_url should not change the behaviour of compilation correct?

If this is worthy of a new thread I can do just that.

Thanks again!

ADD REPLYlink written 3.6 years ago by marcoalbuquerque.sfu50

Actually, the order matters :(

ADD REPLYlink written 3.6 years ago by Bjoern Gruening5.1k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 137 users visited in the last hour