Question: Workflows don't execute after successfully being invoked at https://usegalaxy.org -- RESOLVED, read for details
2
gravatar for jomiles26
4 weeks ago by
jomiles2650
jomiles2650 wrote:

I've been trying to execute two workflows on several of my datasets, but they won't execute. I get the message to say that they've successfully been invoked, but then nothing happens and no new datasets are generated - either in the current history, or in a new history. I'm not close to my data quota either (42 of 250 GB used on Galaxy Main). Could this be a problem connecting with the server? If so, what can I do about it?

The workflows I'm using are:

  1. CloudMap hawaiian variant mapping with WGS and variant calling workflow (no candidate genes)

  2. VCF to snpeffs uwml

workflow usegalaxy.org galaxy • 249 views
ADD COMMENTlink modified 23 days ago by Jennifer Hillman Jackson25k • written 4 weeks ago by jomiles2650
1

I've run both of these workflows successfully before - they just suddenly stopped working today. The cloudmap workflow is:

https://usegalaxy.org/workflow/display_by_id?id=d99d0984a42d9837

And the other is:

https://usegalaxy.org/workflow/display_by_id?id=824b6205aa40ff3b

ADD REPLYlink written 4 weeks ago by jomiles2650

I ran into some other problems with workfow tests, too. Our admin is out today, so it may not be until Monday when we get back to you with more (noting a fix or a link to an issue ticket).

Thanks for reporting the problem and sorry for the current inconvenience! Jen

ADD REPLYlink written 4 weeks ago by Jennifer Hillman Jackson25k
1

Hi, Wonder if anyone can help? I have created a workflow but despite invoking does not appear in the history. It has not been sent to a different history. It appears similar to a problem users had 7 months ago. Wondering how best to resolve this?

Thanks, Josh

ADD REPLYlink written 4 weeks ago by joshezhang.tfg10

Hi Josh - please see the discussion and new issue ticket in the primary reply. We will also post back here with another update once resolved. Thanks for reporting the issue and hope that clears up current status.

ADD REPLYlink written 29 days ago by Jennifer Hillman Jackson25k

Could you share links to the workflows? There can be multiple version of these on the server and I want to make sure I am looking at the exact version you are using.

I can probably find your originating histories, so you don't need to share them publically. Will write back for more info if needed with how to share privately.

Btw - The Cloudmap workflow and tools are deprecated so that one may not be functional anymore (but a different error message should come up, not a launch with no other information). I'm not sure about the other but will review once I have the link.

Thanks, Jen, Galaxy team

ADD REPLYlink written 4 weeks ago by Jennifer Hillman Jackson25k
1
gravatar for Jennifer Hillman Jackson
23 days ago by
United States
Jennifer Hillman Jackson25k wrote:

UPDATE 7-27-2018

The Workflow execution issues have been resolved at https://usegalaxy.org.

New or existing workflows will execute when the results are sent back to the original history or sent to a new history.

Important note: Prior workflows launched during this problematic time frame had the workflow jobs in a queued state. These are now running or have already run. Be sure to check your histories for this content and permanently delete (purge) any datasets or histories that ended up with duplication (due to multiple invocations of a workflow). FAQ for purging data: https://galaxyproject.org/learn/managing-datasets/#delete-vs-delete-permanently

Thanks to everyone for your patience and feedback while we resolved the problems! Jen, Galaxy team

ADD COMMENTlink modified 23 days ago • written 23 days ago by Jennifer Hillman Jackson25k
1

That's great! Thank you :)

ADD REPLYlink written 23 days ago by jomiles2650
1
gravatar for Jennifer Hillman Jackson
4 weeks ago by
United States
Jennifer Hillman Jackson25k wrote:

Update: We can confirm the problem with workflow execution. This is the issue ticket with details: https://github.com/galaxyproject/usegalaxy-playbook/issues/151

The current execution problems just started late last week and impact all workflows (new or existing). We are working on a solution. As we work through the problem, technical details and possible workarounds will post both to the issue ticket. Once resolved, both will also be updated and closed out.

If others have questions about this same problem, review this post and the issue ticket first. Should you want or need to comment that you are also running into the issue, that is fine, but please do not post as an answer - instead post as a comment. Please do not start another duplicated post.

Thanks again for reporting this, it is new. Jen, Galaxy team

ADD COMMENTlink modified 29 days ago • written 4 weeks ago by Jennifer Hillman Jackson25k
1

Ok, thanks for keeping me updated.

ADD REPLYlink written 4 weeks ago by jomiles2650

The problem is still ongoing. July 25.

ADD REPLYlink written 26 days ago by Amir.Taheri.Ghahfarokhi20

Yes, we are still working on it, thanks!

ADD REPLYlink written 26 days ago by Jennifer Hillman Jackson25k

Hi Jen, Workflow execution is still an issue. Kindly address the issue at the earliest.

I'm getting the below error.

Successfully invoked workflow Workflow constructed from history 'primary tumor'.

You can check the status of queued jobs and view the resulting data by refreshing the History pane, if this has not already happened automatically.

But I cannot view anything.

Thanks, Jaswanth. P.

ADD REPLYlink written 24 days ago by jaswanth.p0
1

The current status is that Workflows are still problematic and being worked on.

ADD REPLYlink modified 23 days ago • written 24 days ago by Jennifer Hillman Jackson25k

Is this problem solved ? (31.7.18). Because some of my Workflow now work.

Thanks Lorenzo

ADD REPLYlink written 20 days ago by sennalollo0

Yes, see the accepted reply above: https://biostar.usegalaxy.org/p/28818/#28950

ADD REPLYlink written 20 days ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 153 users visited in the last hour