Question: Selecting multiple datasets after filtering
1
gravatar for matt.chambers42
14 months ago by
matt.chambers4250 wrote:

Something changed about the multiple dataset selection control. I used to be able to filter for a string like "_1" or "_2" and then easily select all the results. Now I have to manually click each item in the filtered list to select it. Is there a way to get the old behavior?

galaxy • 352 views
ADD COMMENTlink modified 14 months ago by Jennifer Hillman Jackson25k • written 14 months ago by matt.chambers4250
1

Have you changed the browser programme you use. I find different behaviour between chrome and Safari? Are you typing in the filter criterion or pasting them in? If you are doing the latter, try deleting the last character and retyping it. Does it then work? Cheers Guy

ADD REPLYlink written 14 months ago by Guy Reeves1.0k

Guy's advice is good. If that does not work, or even if that does, some more details will help. If there is a Galaxy software problem, we will want to correct it. If a tool problem, that can sometimes be addressed by us or by working with the tool developer.

  • Are you working at http://usegalaxy.org? Or elsewhere (URL of the other Public server)? If a local, what version of Galaxy is in use?
  • Which tool are you using and version? The version is at the top of the tool form
  • Which browser are you using (version) and OS (MAC OSX or other? version?)

Thanks! Jen, Galaxy team

ADD REPLYlink modified 14 months ago • written 14 months ago by Jennifer Hillman Jackson25k
2

I'm using the latest release_17.05 from GitHub on a Jetstream instance. Chrome 58.0.3029.110 on Windows 7. I'm trying this on HISAT, but it's hard to imagine that it's a tool problem because the input form allows selecting multiple inputs, it just doesn't let me select them all at once (like it did with 17.01).

ADD REPLYlink modified 14 months ago • written 14 months ago by matt.chambers4250
1
gravatar for Jennifer Hillman Jackson
14 months ago by
United States
Jennifer Hillman Jackson25k wrote:

Hi Matt,

Thanks for reporting the change in the user interface behavior.

I can confirm that the filtering functionality is no longer present for multi-select. I tested in a 17_01 local Galaxy and it was not present there either, nor is it available in 17_05. This filtering feature was addressed in a much earlier release (see the ticket below for that change, it is linked in). When exactly the functionality was lost is not clear but we agree it would be nice to have it back!

I am using a MAC, so that might be a factor, however, it seems more likely that a Galaxy version prior to 17_01 is where you were able to filter with multi-select before.

I opened a ticket for the development team to review and consider adding it back in. Please see the details here, where you can also follow updates: https://github.com/galaxyproject/galaxy/issues/4215

The workaround is to use a Dataset collection instead of multi-select. This is how: https://galaxyproject.org/tutorials/collections/

Thanks again! Jen, Galaxy team

ADD COMMENTlink modified 14 months ago • written 14 months ago by Jennifer Hillman Jackson25k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 153 users visited in the last hour