Question: Error in Cuffdiff analysis with reference genome build
1
gravatar for Koushik
7 months ago by
Koushik10
Koushik10 wrote:

Hello All,

I am using cuffdiff for my differential gene expression analysis. I am doing three comparison and trying to find out the DEG. Now after running cuffquant, the output file i,e "abundances.cxb" file I have used as a input file in the Cuffdiff. In cuffdiff I am getting the error "cannot find genomic sequence file ........._GL383546v1_alt{.fa,.fasta}, This contig will not be bias corrected". Though I got output from one comparison. I couldn't understand whats the exact error is. If you kindly help me then it will be highly appreciated.

Thanks.

ADD COMMENTlink modified 7 months ago • written 7 months ago by Koushik10
0
gravatar for Jennifer Hillman Jackson
7 months ago by
United States
Jennifer Hillman Jackson23k wrote:

Hello,

I am not sure where you are working, but perhaps not http://usegalaxy.org? Let us know if working there.

Potential failure reasons:

  • A genome build (the "database" metadata attribute or the genome selected on the tool form) is not indexed properly for the tool
  • A custom genome/build is being used and it is not formatted correctly
  • Try a rerun. This could be a transient server issue. That would explain prior successful runs, assuming the same inputs/tool options were used.

An actual data/tool problem where the index exists but is not available to the same tool for all jobs using it is something that should be looked at. If this is occurring at http://usegalaxy.org, please share more details. What "database" assigned is to the inputs and/or the "genome" selected on the tool form would be a good start.

Two options to avoid the error that do not require any changes (and may be the workaround if there is a problem that needs to be fixed):

  1. Do not use the bias correction option. This requires the genome as an input and is an optional parameter.

  2. Use a Custom genome instead, and promote it to a Custom build.

    • Assign the Custom build as the "database" for input datasets and/or use it from the history (usage varies between tools)
    • Custom genome help: https://galaxyproject.org/learn/custom-genomes/
    • Be sure the format is correct (how-to in link above)
    • Poor custom genome formatting could also cause this type of error

Thanks! Jen, Galaxy team

ADD COMMENTlink modified 7 months ago • written 7 months ago by Jennifer Hillman Jackson23k
0
gravatar for Koushik
7 months ago by
Koushik10
Koushik10 wrote:

Thanks for your suggestions. I am not using the galaxy for my analysis. However I saw in my TOPHAT result, the overall mapping rate is pretty low, something around 40.2%. I couldn't understand what should I do to get the high mapping rate in my data.

Thanks.

ADD COMMENTlink written 7 months ago by Koushik10

Sequence quality/content could be a factor as could the parameters used. Learn more about Tophat at the developer's website and potentially other forums that focus on the line-command use of this tool and related tools.

ADD REPLYlink written 7 months ago by Jennifer Hillman Jackson23k
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 88 users visited in the last hour