Question: DIAMOND on Galaxy
0
gravatar for cryomics
2.4 years ago by
cryomics0
cryomics0 wrote:

I'm getting an error "Insufficient arguments. Use diamond -h for help." whenever I try to run the DIAMOND module from usegalaxy.org or test.galaxyproject.org.

I suspect that in the background diamond has been upgraded from 0.6.13 (the claimed version) to 0.7.10 but that the modules have not been updated to account for the differences in command line flags between the versions. Can anyone verify this or make any other suggestions on getting it to work?

software error galaxy • 1.0k views
ADD COMMENTlink modified 17 months ago by Bjoern Gruening5.1k • written 2.4 years ago by cryomics0
0
gravatar for Bjoern Gruening
2.4 years ago by
Bjoern Gruening5.1k
Germany
Bjoern Gruening5.1k wrote:

Hi,

I answered on github: https://github.com/galaxyproject/tools-iuc/pull/465#issuecomment-208751740

But to fix this problem we need to have a more detailed error message.

Thanks, Bjoern

ADD COMMENTlink written 2.4 years ago by Bjoern Gruening5.1k
0
gravatar for cryomics
2.4 years ago by
cryomics0
cryomics0 wrote:

That's the extent of the error message. In the history it shows up green as if it completed, but the output is empty and the error is shown in the preview box.

galaxy diamond error

ADD COMMENTlink modified 2.4 years ago • written 2.4 years ago by cryomics0

Is this now fixed for you?

ADD REPLYlink written 2.3 years ago by Bjoern Gruening5.1k

Hello,

I am also having the exact same problem. What could I do to look for a solution? Thanks

ADD REPLYlink written 18 months ago by souzatm0
0
gravatar for chryzoumas
18 months ago by
chryzoumas0
chryzoumas0 wrote:

Greetings,

I seem to be having exactly the same problem (empty output, "Insufficient arguments. Use diamond -h for help." message)

ADD COMMENTlink written 18 months ago by chryzoumas0
0
gravatar for Bjoern Gruening
17 months ago by
Bjoern Gruening5.1k
Germany
Bjoern Gruening5.1k wrote:

We have updated the Diamond wrapper last week and fixed hopefully all issues. Let me know if it does not work for you.

ADD COMMENTlink written 17 months ago by Bjoern Gruening5.1k

Hi Bjoern! I am running Diamond as above but still facing the same error ("insufficient arguments. Use diamond -h for help"). In order to be clear this is what I did:

  1. Created a diamond_database (customized by uploading my own protein sequences, format = .fasta) using --> Diamond makedb
  2. Uploaded my nucleotide sequences (format = .fasta)
  3. Set up Diamond (I changed: blast parameter, from Blastp --> Blastx according to my data, reference database --> as point 1).

The rest of the parameters was as the same as default.

However I still get the same "error".

Can you help me?

Thank you in advance

Luca

ADD REPLYlink written 16 months ago by luca.marisaldi30

I have just tried running diamond in the same way as Luca, and get the same error: viz. Insufficient arguments. Use diamond -h for help. David

ADD REPLYlink written 15 months ago by david.hughes0

Can you tell me the version of the tool you are using please?

ADD REPLYlink written 15 months ago by Bjoern Gruening5.1k

Hello! I am having the same problem, here is what I found regarding the version of the tool:

Galaxy Tool ID: toolshed.g2.bx.psu.edu/repos/bgruening/diamond/bg_diamond/0.1.6.0 Galaxy Tool Version: 0.1.6.0 This tool requires diamond (Version 0.6.13)

I am using the main Galaxy instance.

Thanks,

Silvia

ADD REPLYlink written 15 months ago by silvia.raineri0

Sorry, I forgot to mention:

Job dependencies diamond tool_shed_package 0.6.13

ADD REPLYlink written 15 months ago by silvia.raineri0

I am using the main galaxy instance usegalaxy.org). It says: Diamond alignment tool for short sequences against a protein database (Galaxy Version 0.1.6.0)

ADD REPLYlink written 15 months ago by david.hughes0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 69 users visited in the last hour