Question: 'error loading field data' when using tools in workflow interface
1
gravatar for Guy Reeves
20 months ago by
Guy Reeves920
Germany
Guy Reeves920 wrote:

 

Hi 

I am trying to set up a galaxy instance at our institute, our IT person made a 'standard installation'.    All appears to work including the basic tools ( I have checked out some of the tools e.g. upload, text manipulation- and they do indeed work) .    However if try to use any tool  to construct a workflow I get 'error loading field data'  in red text in the  workflow interface just below the tool name.

Does anybody know what has gone wrong and how I can fix it?

Thanks

Guy

 

 

 

ADD COMMENTlink modified 20 months ago • written 20 months ago by Guy Reeves920
0
gravatar for Jennifer Hillman Jackson
20 months ago by
United States
Jennifer Hillman Jackson22k wrote:

Hello Guy,

Does the tool panel include only tools that were installed from the Tool Shed or some that are custom (locally wrapped)? This error has been reported to before when custom tools are present and there was a problem with the tool name/id. 

I am getting feedback from our team to help with specifics, but the more details you can share the better.

Thanks! Jen, Galaxy team

ADD COMMENTlink written 20 months ago by Jennifer Hillman Jackson22k

 

Hi Jen 

No other tools have been installed other than those that came with the basic installation (under the headings 'Get Data'  ..  to 'Graph/Display Data'.

Thanks

guy

ADD REPLYlink written 20 months ago by Guy Reeves920

Odd. Is the most current version running? Use "git log" to check if current: https://wiki.galaxyproject.org/Admin/GetGalaxy#Keep_your_code_up_to_date

I'd like to see if I can replicate, but need to know where you are. Also, updating (if there are new updates, these often include bug fixes when mid-releases) is a good idea in general, as you know :) Workflows have undergone recent changes.

Update: meanwhile, I test the editor on the default install that is most current now, with no additional changes as a base-line.

Tx!

ADD REPLYlink modified 20 months ago • written 20 months ago by Jennifer Hillman Jackson22k

Hi Guy, update from Dannon - would you be able to post "The galaxy-side log corresponding to that request". This would help us to understand more. None of us have seen this before. Thanks! Jen

ps: If this log is very long or you are not sure where this portion it is, send it into galaxy-bugs@lists.galaxyproject.org.

ADD REPLYlink written 20 months ago by Jennifer Hillman Jackson22k
0
gravatar for Guy Reeves
20 months ago by
Guy Reeves920
Germany
Guy Reeves920 wrote:

 

Hi  Jen and Dannon

I checked the  most recent version was not running so I did 

% git pull

and restarted galaxy 

This all went fine until I 

 Error: pg_config executable not found.

  Please add the directory containing pg_config to the PATH

    or specify the full executable path with the option:

        python setup.py build_ext --pg-config /path/to/pg_config build ...

        or with the pg_config option in 'setup.cfg'.

        ----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-iTy4n9/psycopg2

I do not have the privileges to resolve this issue which relates to having PostgreSQL installed ( as I understand it)??

So I guess I will have to wait until the our IT guy (who did the installation) comes back from holiday next week and deals with this.  

Currently I cannot get Galaxy up and running so I cannot send a log unfortunately.

I am very keen to get our galaxy server up and running and  keep trying.

Thanks

Guy

ADD COMMENTlink written 20 months ago by Guy Reeves920

 

Update :

The system admin has now installed PostgreSQL on the server .

But now gets the following error at start up which fails with 

ImportError: /home/galaxy/galaxy/.venv/lib/python2.6/site-packages/pysam/libchtslib.so: undefined symbol: gzopen64
 

He suspects that samtools is a problem ('as it often has problems with zlib libraries'). But as has as I know there is no SAM tools in the basic installation (we have not installed any tools yet).  Is that case ?

Thanks

Guy

ADD REPLYlink written 20 months ago by Guy Reeves920

Yes, the first tool to install for Galaxy server is SAMTools. Obtain the most currently version from the Tool Shed. Jen

ADD REPLYlink written 20 months ago by Jennifer Hillman Jackson22k

Thanks Jen.  That is useful to know in trouble shooting this.

ADD REPLYlink written 20 months ago by Guy Reeves920
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 79 users visited in the last hour