Question: Css behavior with fastqc html report
0
gravatar for marc.chakiachvili
3.1 years ago by
France
marc.chakiachvili10 wrote:

Hi all, 

I am currently working on a our galaxy instance, when I use fastqc tool shed, the html report, though file correctly generated, loose its style tag, (in fact all header related tag in html final output in browser). any relation ti a process inside galaxy files which remove automatically all "non-body' tag from central iframe ?

 

Thanxs if you have seen this problem (and solved it ! :-).

 

fastqc css • 945 views
ADD COMMENTlink modified 3.1 years ago • written 3.1 years ago by marc.chakiachvili10

I have never seen this? Do you run the latest FASTQC version from the TS? Which browser? Do you have any individual modifications to Galaxy running?

ADD REPLYlink written 3.1 years ago by Bjoern Gruening5.0k

Here is a link to my history in usegalaxy, https://usegalaxy.org/u/marc-logic/h/cssfastqcnotloaded

Thanxs for your help.

ADD REPLYlink written 3.1 years ago by marc.chakiachvili10

This here https://usegalaxy.org/datasets/bbd44e69cb8906b5adff7d159f36f794/display/?preview=True looks fine in my browser? Not in yours?

ADD REPLYlink written 3.1 years ago by Bjoern Gruening5.0k

Nop, not in mine, if you check the content, there is no 'HTML' BODY etc. tag in content 

Here is the start content :

sample_1.fq FastQC Report<div class="header"><div id="header_title"><img alt="FastQC" src="" />Fast ....

In the file generated on disk (XXX.dat) the content is 

<HTML>
<HEAD>
<TITLE>sample_1.fq FastQC Report</TITLE>
<STYLE>
the famous missing styles tags
</STYLE>
...

 

Hope it helps :-)

 

ADD REPLYlink written 3.1 years ago by marc.chakiachvili10
0
gravatar for marc.chakiachvili
3.1 years ago by
France
marc.chakiachvili10 wrote:

Hi, I used the tool shed from iuc (version /home/galaxy/shed_tools/toolshed.g2.bx.psu.edu/repos/iuc/fastqc/2611a96c30b7/fastqc)

it has a dependency to /home/galaxy/tool_dependency_dir/fastqc_dist_0_10_1/0.10.1/iuc/fastqc/2611a96c30b7.

the .dat file contains all content (i.e html tag and header content -style / title etc...) but when displayed in main iframe, all geot removed.

It occurs on IE, chrome and firefox.

the fastqc py wrapper rgFastQC.py) add some content at the end of the file, (by the way, it breaks the html as the content is appended after the /html tag). But even when directly modifying the .dat file, only the content of body tags are displayed, even more, the title tag get removed, but not its content (ie. the actual title)

I don't think I modified something in galaxy main configuration which can have an impact on this behaviour.

PS : I tried as well on usegalaxy.org, uploaded my fastq file, run FastQC Read Quality reports (Galaxy Tool Version 0.63) and have the same result. no Css loaded :-(

 

 

 

 

ADD COMMENTlink written 3.1 years ago by marc.chakiachvili10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 90 users visited in the last hour