Question: fastq groomer dependency problem
gravatar for ritar
7 months ago by
ritar10 wrote:


We have a local galaxy instance and I just installed fastq groomer but it really doesnt want to work. Error : /home/galaxy/galaxy/database/jobs_directory/005/5145/ line 9: gx-fastq-groomer: command not found

It does says it needs galaxy_sequence_utils 1.1.1 but I can t find in the tool shed (maybe I m just a bit blind).

Any ideas?


ADD COMMENTlink modified 6 months ago • written 7 months ago by ritar10
gravatar for Jennifer Hillman Jackson
7 months ago by
United States
Jennifer Hillman Jackson25k wrote:


First, make sure that you are using the most recent version of Galaxy 17.09.

If you are not running this release version, try updating. How-to is explained in the Galaxy release notes.

Even if you are running this version, I would suggest updating again anyway to capture any point changes made since the initial release. This ensures your instance is current.

After backing up and then updating Galaxy, delete the old version of the installed Groomer tool and try a reinstall. Then test the tool.

If that does not resolve the problem, please write back and confirm that the instance is current and this version of the Groomer was re-installed. We can troubleshoot more from that baseline. There are currently no known install issues for this tool, but I'll also run a quick test using 17.09 and this tool/version and will get back to you about that once done.

Also, as a side comment (unrelated to the install problems), the need to use the Fastq Groomer tool is not as common as it once was. Maybe double check to see if you can skip it? Please see the first two FAQs here for details:

Let us know how this goes! Jen, Galaxy team

ADD COMMENTlink modified 7 months ago • written 7 months ago by Jennifer Hillman Jackson25k
gravatar for ritar
6 months ago by
ritar10 wrote:

Thank you Jen,

I did something else for the time being : installed an older version of fastq groomer. It works perfectly.

So I do think that updating my galaxy version will work. Will do that soon. Thanks

(and thanks for the heads up on the fastq datatypes. I need to installed the other datatypes and it should work without the groomer.


ADD COMMENTlink written 6 months ago by ritar10

Good news!

Installing tool versions that are in the same publish-date range as the Galaxy release can be a solution, too, for cases like yours. It does assume the prior tool version was not buggy, prompting the need for an update in the first place, but I don't think that is the case for the Groomer. This tool was updated to fit the newer dependency handling methods and updated utils functions, not to resolve any issues with functionality.

The Galaxy release notes describe the changes made for the core distributions and the Tool Shed's has links to tool development repositories that describe the changes made over time and incorporated into released versions. That information can help whenever older versions are used but presenting with problems (admin or functionality based).

Update Galaxy when you can - it will make other tool installs easier and capture functionality improvements, bug fixes, and security upgrades (the latter is the most important reason to stay current, especially if the server is hosted publically). The next Galaxy release comes out soon (18.01). You might want to wait for that and do all the updates at once.


ADD REPLYlink modified 6 months ago • written 6 months ago by Jennifer Hillman Jackson25k
Please log in to add an answer.


Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 130 users visited in the last hour