Question: Attribute error when running some tools after updating to galaxy 17.05
0
gravatar for david.roquis
8 months ago by
david.roquis20
david.roquis20 wrote:

Dear Galaxy Community,

I recently update my cluster-oriented local instance of Galaxy from version 17.01 to 17.05. Since then, I have faced an issue with some of my tools (such as bismark methylation extractor, which I got from the toolshed). Galaxy is unable to finish any of the jobs with this tool and display the following error message

Traceback (most recent call last):
  File "/mnt/extStorage/galaxy-app/lib/galaxy/jobs/runners/__init__.py", line 630, in finish_job
    job_state.job_wrapper.finish( stdout, stderr, exit_code )
  File "/mnt/extStorage/galaxy-app/lib/galaxy/jobs/__init__.py", line 1301, in finish
    dataset.set_peek()
  File "/mnt/extStorage/galaxy-app/lib/galaxy/model/__init__.py", line 2031, in set_peek
    return self.datatype.set_peek( self, is_multi_byte=is_multi_byte )
  File "/mnt/extStorage/galaxy-app/lib/galaxy/datatypes/data.py", line 782, in set_peek
    dataset.peek = get_file_peek( dataset.file_name, is_multi_byte=is_multi_byte, WIDTH=WIDTH, skipchars=skipchars, line_wrap=line_wrap )
  File "/mnt/extStorage/galaxy-app/lib/galaxy/datatypes/data.py", line 1007, in get_file_peek
    temp = compression_utils.get_fileobj( file_name, "U" )
  File "/mnt/extStorage/galaxy-app/lib/galaxy/util/compression_utils.py", line 32, in get_fileobj
    return zipfile.os_zipfile(filename, cmode)
AttributeError: 'module' object has no attribute 'os_zipfile'

The tool was working without any issues prior to upgrading galaxy, and now all jobs fail this way. The tool generate three reports (in the form of a text file) and a gzipped file containing several more (large) text files). Would anyone has a clue about what's going on?

Sincerely

David

ADD COMMENTlink modified 8 months ago by Daniel Blankenberg ♦♦ 1.7k • written 8 months ago by david.roquis20
1
gravatar for Daniel Blankenberg
8 months ago by
Daniel Blankenberg ♦♦ 1.7k
United States
Daniel Blankenberg ♦♦ 1.7k wrote:

Hi David,

Is it possible that you have a ZIP file instead of a gzip'd file? A potential fix has been submitted here: https://github.com/galaxyproject/galaxy/pull/4135.

If you like, you can try to apply the patch before it is committed and let us know if it helps (https://github.com/galaxyproject/galaxy/pull/4135.patch).

Thanks for using Galaxy,

Dan

ADD COMMENTlink modified 8 months ago • written 8 months ago by Daniel Blankenberg ♦♦ 1.7k

Hi Dan,

Thanks for this very quick answer. I have applied the fix, and it now works flawlessly!

Sincerely

David

ADD REPLYlink written 8 months ago by david.roquis20
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 119 users visited in the last hour