Question: Workflow execution of "Join two Datasets" tool
1
gravatar for jamieson.pierce
7 months ago by
jamieson.pierce10 wrote:

I'm trying to use a workflow that includes one step where I take two datasets with similar columns and perform a "Join two Datasets" operation. I've done this manually, and it works perfectly whenever I do it. However, when I run a workflow to do this automatically, it always returns an error -- "Error parsing command line".

This isn't a critical issue, as I can still do my work without this functionality, but it would be nice if this worked.

tool workflow join • 165 views
ADD COMMENTlink modified 7 months ago by Jennifer Hillman Jackson23k • written 7 months ago by jamieson.pierce10

Hello, This function was working at http://usegalaxy.org last time I checked. However, we are in the process of updating the source code on the server. I'll test and see if can reproduce the problem. Feedback soon! Thanks for reporting the issue so clearly, Jen, Galaxy team

ADD REPLYlink modified 7 months ago • written 7 months ago by Jennifer Hillman Jackson23k
0
gravatar for Jennifer Hillman Jackson
7 months ago by
United States
Jennifer Hillman Jackson23k wrote:

Hello,

This tool is working as expected at Galaxy Main http://usegalaxy.org. This is true whether run within a history directly or within a workflow. I also tested a related join tool and that also worked as expected.

Start troubleshooting by checking the tool setting versus the input data contents. Why there are different results could also be because the direct run tool options differ from the workflow tool options. The test I ran was very simple and can be reviewed here:

Should you be running a local Galaxy, make sure that it is current with the latest Galaxy release and with the most current tool version(s). Note that the tool "Join two Datasets" comes with Galaxy pre-installed. The related tool tested "Join two files" is installed from the tool shed.

If you need more help, please let us know. Jen, Galaxy team

ADD COMMENTlink written 7 months ago by Jennifer Hillman Jackson23k

Hey thanks for your help with this Jen, I was able to troubleshoot it using your examples. You're doing a really excellent and thankless job with all this support. Thank you

ADD REPLYlink written 7 months ago by jamieson.pierce10
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 117 users visited in the last hour