Question: installation toolshed errors - realigner target creator
0
gravatar for pwsmit
2.7 years ago by
pwsmit0
Netherlands
pwsmit0 wrote:

Hi, 

I installed galaxy on Ubuntu and I try to keep it as simple as possible so do not use any other program in combination with galaxy. I followed all installation steps and managed to set-up the tools depency as described. However, I keep running into issues with various tools, (I managed to solve another issue related to samtools by installing it using sudo apt-get install samtools). 

 

I completed the following accordingly: https://wiki.galaxyproject.org/Admin/Tools/AddToolFromToolShedTutorial

I got completely stuck with the following: https://wiki.galaxyproject.org/Admin/Config/ToolDependencies

 

By using realigner target creator I get error: 

/bin/sh: 1: java: not found. 

my $PATH seems to give incorrect results:

$PATH:

bash: /bin:/usr/bin: /usr/X11R6/bin:/usr/local/bin: File does not exist

I tried to do various adjustments to the path but did not seem to work OK.. Help would be greatly appreciated! and sorry but my knowledge is very limited, I am definitely no expert! 

 

Many thanks in advance, 

 

Pieter

samtools • 686 views
ADD COMMENTlink modified 2.7 years ago • written 2.7 years ago by pwsmit0
0
gravatar for Anton Nekrutenko
2.7 years ago by
Penn State
Anton Nekrutenko1.7k wrote:

Pieter:

While we were planning on supporting GATK.  However since they moved to a closed source model we are not planning on supporting GATK. Functionality provided by FreeBayes (which includes leftalign) should be quite comparable to GATK.

a.

ADD COMMENTlink written 2.7 years ago by Anton Nekrutenko1.7k
0
gravatar for Jennifer Hillman Jackson
2.7 years ago by
United States
Jennifer Hillman Jackson23k wrote:

Hello,

Update: This is additional information to consider after following Anton's advice for this specific tool set. Making sure that basic configuration is correct will help with all tools.

Are you certain that java is installed on your system? It should be by default as far as I know. But if you are missing it for some reason, install it and then add it to your path. Dependency paths need to be available to the "galaxy user" (administrator). 

For the second link regarding tool dependencies, much of this is no longer needed and so the content is a bit outdated in some of the specific configuration details. Instead, when installing tools, make certain that the option to install repository dependencies remains checked when submitting the install request through the Admin panel function. Most, if not all, of commonly used tools now have managed dependencies through the Main Tool Shed http://usegalaxy.org/toolshed.

This includes the samtools repository, so I am not sure why it was necessary to install the binary as a distinct process, if using the Admin functions along with the Main Tool Shed. This could be a clue as to where the actual problems are coming from. Perhaps you are installing from a different Tool Shed? Or possibly using an older version of Galaxy itself? Many tools have been recently upgraded and require the latest release.
http://wiki.galaxyproject.org/DevNewsBriefs

Hopefully this helps, Jen, Galaxy team

 

ADD COMMENTlink modified 2.7 years ago • written 2.7 years ago by Jennifer Hillman Jackson23k
0
gravatar for pwsmit
2.7 years ago by
pwsmit0
Netherlands
pwsmit0 wrote:

Dear Jennifer, 

Many thanks, it helped! it all works woohooo!!! 

ADD COMMENTlink written 2.7 years ago by pwsmit0
Please log in to add an answer.

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 101 users visited in the last hour