User: esch0041

gravatar for esch0041
esch004160
Reputation:
60
Status:
Trusted
Location:
Last seen:
5 months, 1 week ago
Joined:
2 years ago
Email:
e*******@umn.edu

Posts by esch0041

<prev • 8 results • page 1 of 1 • next >
1
vote
1
answer
148
views
1
answer
planemo test - mysterious samtools dependency
... When I run planemo test for a tool that has declared no dependencies on samtools, I nevertheless see the following in the output > 2018-01-08 19:01:58,214 DEBUG [galaxy.tools.deps] Building dependency shell command for dependency 'samtools' > 2018-01-08 19:01:58,215 DEBUG [galaxy.tools.deps] ...
planemo written 5 months ago by esch004160 • updated 5 months ago by jmchilton1.1k
2
votes
2
answers
336
views
2
answers
Answer: A: toolshed repository - "This revision can be installed: False" - why?
... I don't see anything in the [XML reference for comments][1] saying that they cannot appear outside the root element. Planemo serve, test, lint and shed_lint all worked fine with my tool definition XML, which ended with an XML comment that serves as a "vim modeline". Vim modelines are instructions ...
written 13 months ago by esch004160
1
vote
2
answers
336
views
2
answers
Comment: C: toolshed repository - "This revision can be installed: False" - why?
... Thanks, Bjoern. Indeed the files are present in the repository on the testtoolshed (when I browse tip and when I hg clone), but even after shed_upload it is still marked `This revision can be installed: False`. Looking at other tools, I cannot spot what I am missing in my repository. ...
written 13 months ago by esch004160
6
votes
2
answers
336
views
5 follow
2
answers
toolshed repository - "This revision can be installed: False" - why?
... I built a tool that passed `planemo test` and `planemo shed_lint`, and I deployed it to a testtoolshed repository using `planemo shed_create` with [the .shed.yml here][1]. When I look at it in the test toolshed [w4mclassfilter][2] the repository browser says "This revision can be installed: False". ...
toolshed written 13 months ago by esch004160
1
vote
1
answer
843
views
1
answers
Comment: C: Planemo tutorial test - "Failed to resolve dependency" "Error loading a set of D
... Martin, Thank you very much for your response. What a difference a few days make! Now, when I run with the same command as before, I still see most or all of the warnings and errors, but my test passes. Granted, I did this with a new virtualenv. I did it outside the VM; previously, my test failed ...
written 24 months ago by esch004160
0
votes
0
answers
647
views
0
answers
Comment: C: Capsule with dependencies - "dependency hierarchy could not be determined"
... I tried resetting the repository metadata for each repository, one at a time. As far as I can tell, this seems to have been effective - I saw no errors when I installed package_r_3_2_1 into my repository. ...
written 24 months ago by esch004160
1
vote
1
answer
843
views
1
answer
Planemo tutorial test - "Failed to resolve dependency" "Error loading a set of Dynamic Display Application links"
... I have been trying to follow the tutorial ["The Basics" under "Building Galaxy Tools ... using Planemo][1] and I have been getting. When I run >` planemo test --install_galaxy --test_output test-output/test_output.dat --test_data test-data/ seqtk_seq.xml` my test fails, and I see several WARN ...
planemo test test dependency planemo written 2.0 years ago by esch004160 • updated 24 months ago by Martin Čech ♦♦ 4.7k
1
vote
0
answers
647
views
0
answers
Capsule with dependencies - "dependency hierarchy could not be determined"
... I have exported package_r_3_2_1 as a capsule including dependencies from https://toolshed.g2.bx.psu.edu/repository?repository_id=9d4c4c6c8e05e067&changeset_revision=d9f7d84125b7 and imported it into a freshly created local tool shed. When I preview package_r_3_2_1 for installation to my freshly ...
galaxy capsule dependencies tool shed written 2.0 years ago by esch004160

Latest awards to esch0041

Scholar 13 months ago, created an answer that has been accepted. For A: toolshed repository - "This revision can be installed: False" - why?

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 113 users visited in the last hour