User: mdgronke

gravatar for mdgronke
mdgronke10
Reputation:
10
Status:
New User
Location:
Last seen:
1 month, 3 weeks ago
Joined:
7 months, 2 weeks ago
Email:
m*******@ncsu.edu

Posts by mdgronke

<prev • 7 results • page 1 of 1 • next >
0
votes
1
answer
132
views
1
answers
Answer: A: Server only works properly when launched as root, not as galaxy user.
... UPDATE: I have 'solved' the issue. Here is my fix. My shed-tool folders were set in the apps/ directory, one directory up and alongside galaxy/. These were not chowned to galaxy. I chowned them to galaxy. Then I reran my systemd service (which executes by root but for user galaxy) and it was able t ...
written 7 weeks ago by mdgronke10
0
votes
1
answer
132
views
1
answers
Comment: C: Server only works properly when launched as root, not as galaxy user.
... Only paths listed are .venv for virtual env, and lib for python, both in the same directory and both owned to galaxy. My tool dependency directory is left to default, so it exists within the galaxy folder as well. ...
written 7 weeks ago by mdgronke10
0
votes
1
answer
132
views
1
answer
Server only works properly when launched as root, not as galaxy user.
... I have a problem where I cannot install or update tools if I launch the server as user galaxy. Here is what I have tried: -Chowning the entire galaxy directory, including all hidden folders, to be owned by galaxy. I've confirmed this has been done. But after launching the server as user galaxy, I ...
server permissions config uwsgi written 7 weeks ago by mdgronke10
1
vote
2
answers
258
views
2
answers
Comment: C: Creating simple tool to downsample sam files, doesn't complete
... I'll check out the downsampling tool, thanks. We're migrating from Mobyle so at the moment I'm trying to figure out which tools already exist in the toolshed. As far as planemo, I have ran a lint on it and it said it validated the xml tags, so I didn't know where the problem lay. ...
written 6 months ago by mdgronke10
2
votes
2
answers
258
views
2
answers
Creating simple tool to downsample sam files, doesn't complete
... I've written a simple tool to downsample files with a script I am running. It appears to run successfully from the std.err output, but it gives a fail when I run it in Galaxy. I'm trying to figure out what's going on. Here's the code: Downsamples a SAM file downsample_ ...
galaxy xml sam mytools tools written 6 months ago by mdgronke10 • updated 6 months ago by Jennifer Hillman Jackson25k
0
votes
1
answer
227
views
1
answers
Answer: A: "When available, install externally managed dependencies (e.g. conda)? Beta" is
... I figured out the problem. I did not have bzip2 installed, which meant the conda install did not properly work. It was shown here when I deleted the _conda/ folder and tried re-running run.sh. galaxy.tools.deps.conda_util INFO 2018-04-06 15:32:19,516 Installing conda, this may take several minutes ...
written 7 months ago by mdgronke10
0
votes
1
answer
227
views
1
answer
"When available, install externally managed dependencies (e.g. conda)? Beta" is nowhere to be found. How to fix?
... I believe I'm running the latest version of Galaxy Project, as I installed it from the site last week, so version 18,01 I am trying to install Trimmomatic from the Tool Shed. I get the message that: "*This repository defines tool requirements that cannot be installed through the Tool Shed.Please ac ...
galaxy conda written 7 months ago by mdgronke10

Latest awards to mdgronke

No awards yet. Soon to come :-)

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 163 users visited in the last hour