User: Thon deBoer

gravatar for Thon deBoer
Thon deBoer20
Reputation:
20
Status:
New User
Location:
Last seen:
4 months, 1 week ago
Joined:
5 years, 10 months ago
Email:
t*********@me.com

Posts by Thon deBoer

<prev • 11 results • page 1 of 2 • next >
1
vote
2
answers
261
views
2
answers
Answer: A: "Tool error: Unable to finish job" on the DOCKER version of galaxy, but not for
... Seems that that neat_genReads tool has a known issue with BAM files not being properly formatted... Get this when trying to read the BAM file [E::bam_read1] CIGAR and query sequence lengths differ for ecoli-chr-268539/1 [main_samview] truncated file. So, this is NOT a problem with Galaxy and I th ...
written 4 months ago by Thon deBoer20
0
votes
2
answers
261
views
2
answers
Comment: C: "Tool error: Unable to finish job" on the DOCKER version of galaxy, but not for
... I updated to the latest Docker version (can't really see what version that is, but guessing 18.something since it had "unsorted.bam as an option). I changed the BAM file format type from "bam" to "unsorted.bam" and this seems to fix the error! Next I just made samtools sort the BAM files to ensure ...
written 4 months ago by Thon deBoer20
0
votes
2
answers
261
views
2
answers
Comment: C: "Tool error: Unable to finish job" on the DOCKER version of galaxy, but not for
... Not sure how to check for version numbers on the Galaxy I am using on Docker and Planemo. I looked in the Planemo build and see a file named: release_17.05_receipt So, guessing Planemo version is 17.05 Could not find something similar for the Docker version, but the git entry TOC goes up to 17.09 ...
written 4 months ago by Thon deBoer20
2
votes
2
answers
261
views
2
answers
"Tool error: Unable to finish job" on the DOCKER version of galaxy, but not for the usual reasons (missing dependencies) nor is it consistent
... I created a wrapper for the NEAT-genReads NGS simulation tool but I am running into the dreaded "Tool error: Unable to finish job", but only on [ecoli-size genomes][1], only on the DOCKER version of Galaxy and NOT because of missing dependencies (which is the usual reason for this error, as I see in ...
docker software error planemo written 4 months ago by Thon deBoer20
4
votes
2
answers
180
views
2
answers
How to write tests for tools that access built-in data from the data tables
... I am writing a tool wrapper for a tool that allows as FASTA file input something from the data-table all_fasta. How do I write tests for these kinds of tools? The tests I wrote that use data provided as test-data in the test-data directory work fine, but I want to test it using the data from a dat ...
planemo data-table development tool tests written 5 months ago by Thon deBoer20 • updated 5 months ago by jmchilton1.1k
0
votes
1
answer
1.3k
views
1
answers
Comment: C: Naming output file according to input file
... Actually..you often don't need the os.path.basename part. That is only needed if you ever pass it a full path (but it doesn't hurt and I just always use it) ...
written 5 months ago by Thon deBoer20
0
votes
1
answer
1.3k
views
1
answers
Answer: A: Naming output file according to input file
... It is possible to use python code in the labels, so this should work: You can't use the { } for the $input1.name, but you DO need it for the python code, but this will do what you want. it will name your output file "myInputFile.something". Adopted from https://stackoverflow.com/questions/6 ...
written 5 months ago by Thon deBoer20
0
votes
1
answer
206
views
1
answers
Comment: C: Force galaxy to use the python 2 version of a dependency of a new tool
... Just checked, and indeed matplotlib is installed using CONDA... genMutModel /home/ubuntu/miniconda3/envs/mulled-v1-808d181c256ea1be661871e558eb70bf5d9047a0855ff85f21331747f4819086 numpy 1.9.1 Conda True /home/ubuntu/miniconda3/envs/mulled-v1-808d181c256ea1be661871e558eb70bf5d9047a0 ...
written 5 months ago by Thon deBoer20
0
votes
1
answer
206
views
1
answers
Comment: C: Force galaxy to use the python 2 version of a dependency of a new tool
... UH?! By using the requirement tag i AM using conda, no? Conda is just one of the dependency resolvers I understand... I am actually using PLANEMO (on the VM) and that is where I see that CONDA is installing the python 3.6 version of all the dependencies ...
written 5 months ago by Thon deBoer20
0
votes
1
answer
206
views
1
answer
Force galaxy to use the python 2 version of a dependency of a new tool
... I am creating a new tool for galaxy based on the NEAT-genReads tool from Zachary Stephens and I am trying to define the dependencies. The tool requires the **matplotlib.pyplot** library since it calls out this import statement: import matplotlib.pyplot as mpl I defined the dependency for the ...
planemo conda development tool dependencies written 5 months ago by Thon deBoer20 • updated 5 months ago by Jennifer Hillman Jackson25k

Latest awards to Thon deBoer

No awards yet. Soon to come :-)

Help
Access

Use of this site constitutes acceptance of our User Agreement and Privacy Policy.
Powered by Biostar version 16.09
Traffic: 136 users visited in the last hour